summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch')
-rw-r--r--media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch b/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch
new file mode 100644
index 000000000000..311aac1a3b74
--- /dev/null
+++ b/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch
@@ -0,0 +1,42 @@
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 2749)
++++ CMakeLists.txt (revision 2750)
+@@ -33,6 +33,10 @@
+ OPTION(ENABLE_UDISKS2 "Build UDisks2 backend, and NOT UDisks, for Qt builds" OFF)
+ OPTION(ENABLE_OVERLAYSCROLLBARS "Enable support for overlay style scrollbars when using QGtkStyle (Linux only)" OFF)
+ OPTION(ENABLE_ONLINE_SERVICES "Enable support for online services (Jamendo and Magantune)" ON)
++OPTION(ENABLE_CDPARANOIA "Enable CDParanoia libraries (required for AudioCD support)" ON)
++OPTION(ENABLE_CDDB "Enable CDDB libraries (either this or MusicBrianz required for AudioCD support)" ON)
++OPTION(ENABLE_MUSICBRAINZ "Enable MusicBrianz libraries (either this or CDDB required for AudioCD support)" ON)
++OPTION(ENABLE_LAME "Enable LAME libraries (required for AudioCD playback support)" ON)
+
+ if (ENABLE_QT5)
+ set(ENABLE_PHONON FALSE)
+@@ -142,12 +146,20 @@
+ SET( CANTATA_UIS ${CANTATA_UIS} online/onlineservicespage.ui)
+ endif (ENABLE_ONLINE_SERVICES)
+
+-find_package( Cdparanoia )
+-if (CDPARANOIA_FOUND)
+- find_package( CDDB )
+- find_package( MusicBrainz5 )
+- find_package( Lame )
+-endif (CDPARANOIA_FOUND)
++if (ENABLE_CDPARANOIA)
++ find_package(Cdparanoia)
++ if (CDPARANOIA_FOUND)
++ if (ENABLE_CDDB)
++ find_package(CDDB)
++ endif (ENABLE_CDDB)
++ if (ENABLE_MUSICBRAINZ)
++ find_package(MusicBrainz5)
++ endif (ENABLE_MUSICBRAINZ)
++ if (ENABLE_LAME)
++ find_package(Lame)
++ endif (ENABLE_LAME)
++ endif (CDPARANOIA_FOUND)
++endif (ENABLE_CDPARANOIA)
+
+ if (ENABLE_TAGLIB)
+ set(TAGLIB_MIN_VERSION "1.6")