summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/portaudio/portaudio-19_pre20071207.ebuild')
-rw-r--r--media-libs/portaudio/portaudio-19_pre20071207.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/media-libs/portaudio/portaudio-19_pre20071207.ebuild b/media-libs/portaudio/portaudio-19_pre20071207.ebuild
index d124376418bb..2c8e9b4158e0 100644
--- a/media-libs/portaudio/portaudio-19_pre20071207.ebuild
+++ b/media-libs/portaudio/portaudio-19_pre20071207.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/portaudio-19_pre20071207.ebuild,v 1.1 2008/01/12 18:16:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/portaudio-19_pre20071207.ebuild,v 1.2 2008/05/19 19:18:11 drac Exp $
-EAPI="1"
+EAPI=1
-MY_PN=pa_stable_v
-MY_PV=${PV/pre/}
-MY_P=${MY_PN}${MY_PV}
+MY_P=pa_stable_v${PV/pre}
DESCRIPTION="An open-source cross platform audio API."
HOMEPAGE="http://www.portaudio.com"
@@ -18,27 +16,24 @@ KEYWORDS="~amd64 ~x86"
IUSE="alsa +cxx debug oss"
DEPEND="alsa? ( media-libs/alsa-lib )"
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_compile() {
# Jack is disabled, it seems to have runtime issues
# Moreover it fails to compile on some arches (like amd64)
# And this could cause cyclic dependencies with jack portaudio support
- econf $(use_with alsa)\
- --without-jack \
- $(use_with oss)\
- $(use_with debug debug-output)\
- $(use_enable cxx) \
- || die "econf failed"
-
- emake || die "emake failed"
+ econf --without-jack \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with debug debug-output) \
+ $(use_enable cxx)
+ emake || die "emake failed."
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install faied"
+ emake DESTDIR="${D}" install || die "emake install failed."
dodoc V19-devel-readme.txt
dohtml index.html
}