summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/glew/glew-1.5.8.ebuild')
-rw-r--r--media-libs/glew/glew-1.5.8.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-libs/glew/glew-1.5.8.ebuild b/media-libs/glew/glew-1.5.8.ebuild
deleted file mode 100644
index 149dbd0945f3..000000000000
--- a/media-libs/glew/glew-1.5.8.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glew/glew-1.5.8.ebuild,v 1.1 2011/03/30 21:13:55 radhermit Exp $
-
-EAPI=4
-inherit multilib toolchain-funcs
-
-DESCRIPTION="The OpenGL Extension Wrangler Library"
-HOMEPAGE="http://glew.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="x11-libs/libXmu
- x11-libs/libXi
- virtual/glu
- virtual/opengl
- x11-libs/libXext
- x11-libs/libX11"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- myglewopts=(
- AR="$(tc-getAR)"
- STRIP=true
- CC="$(tc-getCC)"
- LD="$(tc-getCC) ${LDFLAGS}"
- M_ARCH=""
- LDFLAGS.EXTRA=""
- POPT="${CFLAGS}"
- )
-}
-
-src_prepare() {
- sed -i \
- -e '/INSTALL/s:-s::' \
- -e '/$(CC) $(CFLAGS) -o/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
- Makefile || die
-
- # don't do stupid Solaris specific stuff that won't work in Prefix
- cp config/Makefile.linux config/Makefile.solaris || die
-}
-
-src_compile(){
- emake "${myglewopts[@]}"
-}
-
-src_install() {
- emake \
- GLEW_DEST="${ED}/usr" \
- LIBDIR="${ED}/usr/$(get_libdir)" \
- "${myglewopts[@]}" install
-
- dodoc doc/*.txt README.txt TODO.txt
- dohtml doc/*.{css,html,jpg,png}
-}