summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kxkb/kxkb-3.5.10.ebuild')
-rw-r--r--kde-base/kxkb/kxkb-3.5.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-base/kxkb/kxkb-3.5.10.ebuild b/kde-base/kxkb/kxkb-3.5.10.ebuild
new file mode 100644
index 000000000000..0b7ff78ca25a
--- /dev/null
+++ b/kde-base/kxkb/kxkb-3.5.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kxkb/kxkb-3.5.10.ebuild,v 1.1 2008/09/14 00:00:17 carlo Exp $
+
+KMNAME=kdebase
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-13.tar.bz2"
+
+DESCRIPTION="KControl module for the X11 keyboard extension to configure and switch between keyboard mappings."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility"
+
+DEPEND="x11-libs/libXtst"
+RDEPEND="x11-libs/libXtst
+ || ( x11-misc/xkeyboard-config x11-misc/xkbdata )
+ x11-apps/setxkbmap"
+
+KMEXTRACTONLY="${KMEXTRACTONLY}
+ kdm/configure.in.in"
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ epatch "${WORKDIR}/patches/kdm-3.5-noimake.patch"
+
+ # Remove reference to kde.desktop in AC_OUTPUT to allow building with
+ # autoconf 2.59d
+ sed -i -e '/kde.desktop/ s:^:#:g' "${S}/kdm/configure.in.in"
+}