summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/ChangeLog7
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.2.11
-rw-r--r--kde-base/kdelibs/kdelibs-3.2.1.ebuild84
3 files changed, 91 insertions, 1 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 9c803413dc26..4e9684af47f1 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.124 2004/03/03 15:30:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.125 2004/03/09 12:19:56 caleb Exp $
+
+*kdelibs-3.2.1 (09 Mar 2004)
+
+ 09 Mar 2004; Caleb Tennis <caleb@gentoo.org> kdelibs-3.2.1.ebuild:
+ Version bump
03 Mar 2004; <agriffis@gentoo.org> kdelibs-3.2.0.ebuild:
stable on alpha and ia64
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.2.1 b/kde-base/kdelibs/files/digest-kdelibs-3.2.1
new file mode 100644
index 000000000000..68d1acaca1ef
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.2.1
@@ -0,0 +1 @@
+MD5 50ae60072c1fc4ae4e41694bc2325dcb kdelibs-3.2.1.tar.bz2 12597050
diff --git a/kde-base/kdelibs/kdelibs-3.2.1.ebuild b/kde-base/kdelibs/kdelibs-3.2.1.ebuild
new file mode 100644
index 000000000000..9486eff8214d
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.2.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.2.1.ebuild,v 1.1 2004/03/09 12:19:56 caleb Exp $
+
+inherit kde
+
+need-autoconf 2.5
+set-kdedir ${PV}
+
+DESCRIPTION="KDE libraries needed by all kde programs"
+HOMEPAGE="http//www.kde.org/"
+SRC_URI="mirror://kde/stable/${PV}/src/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.2"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~amd64"
+IUSE="alsa cups ipv6 ssl doc ldap"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+DEPEND=">=sys-devel/autoconf-2.58
+ >=app-arch/bzip2-1.0.2
+ >=dev-libs/libxslt-1.0.31
+ >=dev-libs/libxml2-2.5.8
+ >=dev-libs/libpcre-3.9
+ ssl? ( >=dev-libs/openssl-0.9.6k )
+ alsa? ( media-libs/alsa-lib virtual/alsa )
+ cups? ( >=net-print/cups-1.1.19 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ media-libs/tiff
+ >=app-admin/fam-2.6.10
+ virtual/ghostscript
+ media-libs/libart_lgpl
+ sys-devel/gettext
+ ~kde-base/arts-1.2.1
+ >=x11-libs/qt-3.2.3"
+RDEPEND="${DEPEND}
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ doc? ( app-doc/doxygen )
+ dev-lang/python"
+
+src_unpack() {
+ kde_src_unpack
+}
+
+src_compile() {
+ kde_src_compile myconf
+
+ myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+ myconf="$myconf `use_with alsa` `use_enable cups`"
+
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+ use x86 && myconf="$myconf --enable-fast-malloc=full"
+
+ kde_src_compile configure make
+
+ use doc && make apidox
+}
+
+src_install() {
+ kde_src_install
+ dohtml *.html
+
+ if [ `use doc` ]; then
+ einfo "Copying API documentation..."
+ dodir ${KDEDIR}/share/doc/HTML/en/kdelibs-apidocs
+ cp -r ${S}/apidocs/* ${D}/$KDEDIR/share/doc/HTML/en/kdelibs-apidocs
+ else
+ rm -r ${D}/$KDEDIR/share/doc/HTML/en/kdelibs-apidocs
+ fi
+}
+
+pkg_postinst() {
+ if [ `use doc` ]; then
+ rm $KDEDIR/share/doc/HTML/en/kdelibs-apidocs/common
+ ln -sf $KDEDIR/share/doc/HTML/en/common \
+ $KDEDIR/share/doc/HTML/en/kdelibs-apidocs/common
+ fi
+}