summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kbabel/kbabel-3.5.9.ebuild')
-rw-r--r--kde-base/kbabel/kbabel-3.5.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/kbabel/kbabel-3.5.9.ebuild b/kde-base/kbabel/kbabel-3.5.9.ebuild
new file mode 100644
index 000000000000..8e8ad4d7a3e9
--- /dev/null
+++ b/kde-base/kbabel/kbabel-3.5.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kbabel/kbabel-3.5.9.ebuild,v 1.1 2008/02/20 22:37:20 philantrop Exp $
+
+KMNAME=kdesdk
+EAPI="1"
+inherit db-use kde-meta eutils
+
+DESCRIPTION="KBabel - An advanced PO file editor"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb kdehiddenvisibility"
+
+DEPEND="berkdb? ( =sys-libs/db-4* )"
+
+src_compile() {
+ local myconf=""
+
+ if use berkdb; then
+ myconf="${myconf} --with-berkeley-db --with-db-lib=$(db_libname)
+ --with-extra-includes=$(db_includedir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde_src_compile
+}