summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/nautilus/nautilus-2.8.0.ebuild')
-rw-r--r--gnome-base/nautilus/nautilus-2.8.0.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnome-base/nautilus/nautilus-2.8.0.ebuild b/gnome-base/nautilus/nautilus-2.8.0.ebuild
index 5cd40b00c86c..5e64433f35eb 100644
--- a/gnome-base/nautilus/nautilus-2.8.0.ebuild
+++ b/gnome-base/nautilus/nautilus-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.8.0.ebuild,v 1.3 2004/11/08 20:50:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.8.0.ebuild,v 1.4 2004/11/10 02:44:38 obz Exp $
inherit gnome2 eutils
@@ -72,16 +72,14 @@ src_unpack() {
# add libgnomeprint support
use cups && epatch ${FILESDIR}/${PN}-2-x-printers.patch
- # regenerating only needed with patching
- if use cups || use gstreamer; then
- WANT_AUTOCONF=2.5 autoheader || die
- WANT_AUTOCONF=2.5 autoconf || die
- WANT_AUTOMAKE=1.4 automake || die
- fi
+ # patch to support libexif versions 0.5 and 0.6
+ epatch ${FILESDIR}/${PN}-2-libexif.patch
- # applying patch to optionally remove volumes from the desktop,
- # see bug #51343 <obz@gentoo.org>
-# epatch ${FILESDIR}/${P}-novolumes.patch
+ # and we always need to regenerate now, because we
+ # always apply the libexif patch <obz@gentoo.org>
+ WANT_AUTOCONF=2.5 autoheader || die
+ WANT_AUTOCONF=2.5 autoconf || die
+ WANT_AUTOMAKE=1.4 automake || die
}