summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/ngstar/ngstar-2.1.8.ebuild')
-rw-r--r--games-puzzle/ngstar/ngstar-2.1.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-puzzle/ngstar/ngstar-2.1.8.ebuild b/games-puzzle/ngstar/ngstar-2.1.8.ebuild
new file mode 100644
index 000000000000..926d85f7c3e4
--- /dev/null
+++ b/games-puzzle/ngstar/ngstar-2.1.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8.ebuild,v 1.1 2006/04/11 23:24:16 tupone Exp $
+
+inherit games
+
+DESCRIPTION="NGStar is a clone of a HP48 game called dstar"
+HOMEPAGE="http://cycojesus.free.fr/faire/coder/jouer/ng-star/"
+SRC_URI="http://cycojesus.free.fr/faire/coder/jouer/ng-star/files/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure \
+ --prefix "${GAMES_PREFIX}" \
+ --without-fltk2 || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ egamesinstall
+ dodoc AUTHORS Changelog README TODO
+ prepgamesdirs
+}