summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/fish-fillets/fish-fillets-0.8.0.ebuild')
-rw-r--r--games-puzzle/fish-fillets/fish-fillets-0.8.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-puzzle/fish-fillets/fish-fillets-0.8.0.ebuild b/games-puzzle/fish-fillets/fish-fillets-0.8.0.ebuild
new file mode 100644
index 000000000000..297c087152d6
--- /dev/null
+++ b/games-puzzle/fish-fillets/fish-fillets-0.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/fish-fillets-0.8.0.ebuild,v 1.1 2008/01/02 23:29:14 mr_bones_ Exp $
+
+inherit eutils games
+
+DATA_PV="0.8.0"
+DESCRIPTION="Underwater puzzle game - find a safe way out"
+HOMEPAGE="http://fillets.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
+ mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-mixer-1.2.5
+ >=media-libs/sdl-image-1.2.2
+ X? ( x11-libs/libX11 )
+ media-libs/sdl-ttf
+ >=dev-lang/lua-5"
+
+S=${WORKDIR}/fillets-ng-${PV}
+
+src_compile() {
+ egamesconf \
+ --datadir="${GAMES_DATADIR}/${PN}" \
+ $(use_with X) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
+ rm -f COPYING
+ doins -r * || die "doins failed"
+ newicon images/icon.png fillets.png
+ make_desktop_entry fillets FishFillets fillets
+ prepgamesdirs
+}