summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/gnurobots/gnurobots-1.2.0.ebuild')
-rw-r--r--games-misc/gnurobots/gnurobots-1.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-misc/gnurobots/gnurobots-1.2.0.ebuild b/games-misc/gnurobots/gnurobots-1.2.0.ebuild
new file mode 100644
index 000000000000..eca7176a0db6
--- /dev/null
+++ b/games-misc/gnurobots/gnurobots-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gnurobots/gnurobots-1.2.0.ebuild,v 1.1 2008/11/14 15:34:46 tupone Exp $
+
+inherit games
+
+DESCRIPTION="construct a program for a little robot then set him loose
+and watch him explore a world on his own"
+HOMEPAGE="http://www.gnu.org/directory/games/gnurobots.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="x11-libs/vte
+ dev-scheme/guile"
+
+src_install() {
+ dodoc AUTHORS \
+ ChangeLog \
+ NEWS \
+ README \
+ THANKS \
+ TODO \
+ doc/Robots-HOWTO \
+ doc/contrib
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepgamesdirs
+}