summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/tuxnes/tuxnes-0.75.ebuild')
-rw-r--r--games-emulation/tuxnes/tuxnes-0.75.ebuild34
1 files changed, 15 insertions, 19 deletions
diff --git a/games-emulation/tuxnes/tuxnes-0.75.ebuild b/games-emulation/tuxnes/tuxnes-0.75.ebuild
index b75f6ffc8ce7..8cd6e6b2b484 100644
--- a/games-emulation/tuxnes/tuxnes-0.75.ebuild
+++ b/games-emulation/tuxnes/tuxnes-0.75.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.8 2006/03/23 20:42:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.9 2006/10/18 19:37:48 nyhm Exp $
-inherit flag-o-matic eutils games
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools flag-o-matic eutils games
DESCRIPTION="emulator for the 8-bit Nintendo Entertainment System"
HOMEPAGE="http://tuxnes.sourceforge.net/"
@@ -13,22 +15,17 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X ggi"
-RDEPEND="sys-libs/zlib
- X? ( || (
- (
- x11-libs/libXext
- x11-libs/libICE
- x11-libs/libX11
- x11-libs/libXpm
- x11-libs/libSM )
- virtual/x11 ) )
+RDEPEND="X? (
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libSM )
ggi? ( >=media-libs/libggi-2.0.1 )"
DEPEND="${RDEPEND}
- X? ( || (
- (
- x11-proto/xextproto
- x11-proto/xproto )
- virtual/x11 ) )"
+ X? (
+ x11-proto/xextproto
+ x11-proto/xproto )"
src_unpack() {
unpack ${A}
@@ -36,8 +33,7 @@ src_unpack() {
epatch \
"${FILESDIR}"/${P}-configure.in.patch \
"${FILESDIR}"/${P}-gcc34.patch
- export WANT_AUTOCONF=2.5
- aclocal && automake && autoconf || die "autoconf failed"
+ eautoreconf
}
src_compile() {
@@ -51,7 +47,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
doicon tuxnes.xpm tuxnes2.xpm
dodoc AUTHORS BUGS ChangeLog CHANGES NEWS README THANKS
prepgamesdirs