summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild')
-rw-r--r--games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
index 84a80c94c216..ad87e4bee293 100644
--- a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
+++ b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.2 2005/01/08 00:49:56 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.3 2005/01/10 01:06:40 morfic Exp $
inherit games flag-o-matic
@@ -17,16 +17,26 @@ DEPEND=""
S="${WORKDIR}/glide64_0_7_ME"
-src_compile() {
- # gcc 3.4 at least has a problem with -O3 and inline asm
- replace-flags -O3 -O2
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
epatch ${FILESDIR}/${P}-compile.patch || die "patch failed"
epatch ${FILESDIR}/${P}-inifix.patch || die "patch failed"
use gtk2 && epatch ${FILESDIR}/${P}-gtk2.patch || die "patch failed"
make clean || die "couldn't clean"
+
+ # gcc 3.4 at least has a problem with -O3 and inline asm
+ replace-flags -O3 -O2
sed -i -e "s:CFLAGS.*=\(.*\):CFLAGS=\1 ${CFLAGS}:" Makefile || \
die "couldn't apply cflags"
+
+}
+
+src_compile() {
+ # doesnt like -j2
make || die "couldn't compile"
}