summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/cssc/cssc-1.3.0.ebuild')
-rw-r--r--dev-vcs/cssc/cssc-1.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/cssc/cssc-1.3.0.ebuild b/dev-vcs/cssc/cssc-1.3.0.ebuild
new file mode 100644
index 000000000000..296c861fe339
--- /dev/null
+++ b/dev-vcs/cssc/cssc-1.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/cssc-1.3.0.ebuild,v 1.1 2010/11/07 19:22:17 jer Exp $
+
+EAPI="2"
+
+DESCRIPTION="CSSC is the GNU Project's replacement for SCCS"
+SRC_URI="mirror://gnu/${PN}/CSSC-${PV}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/cssc/"
+SLOT="0"
+LICENSE="GPL-3"
+S=${WORKDIR}/CSSC-${PV}
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ # The large test takes a long time
+ sed -i tests/Makefile.* \
+ -e 's|\([[:space:]]\)test-large |\1|g' || die "sed failed"
+}
+
+src_configure() { econf --enable-binary; }
+
+src_compile() {
+ emake all || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README NEWS ChangeLog AUTHORS || die "dodoc failed"
+}