summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pilrc/pilrc-2.9.ebuild')
-rw-r--r--dev-util/pilrc/pilrc-2.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/pilrc/pilrc-2.9.ebuild b/dev-util/pilrc/pilrc-2.9.ebuild
new file mode 100644
index 000000000000..e140d99409d6
--- /dev/null
+++ b/dev-util/pilrc/pilrc-2.9.ebuild
@@ -0,0 +1,27 @@
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Pilot Resource Compiler"
+HOMEPAGE="http://www.ardiri.com/index.php?redir=palm&cat=pilrc"
+SRC_URI="http://www.ardiri.com/download/files/palm/pilrc_src.tgz"
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86"
+
+src_compile() {
+ cd ${S}
+ pwd
+ use gtk \
+ || myconf="${myconf} --disable-pilrcui"
+ ./configure ${myconf}
+ make || die
+}
+
+src_install () {
+ cd ${S}
+ dobin pilrc
+ if [ -e pilrcui ]
+ then
+ dobin pilrcui
+ fi
+}