summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hexoid/hexoid-0.2.2.ebuild')
-rw-r--r--dev-ruby/hexoid/hexoid-0.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/hexoid/hexoid-0.2.2.ebuild b/dev-ruby/hexoid/hexoid-0.2.2.ebuild
new file mode 100644
index 000000000000..d48b48cbaa34
--- /dev/null
+++ b/dev-ruby/hexoid/hexoid-0.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hexoid/hexoid-0.2.2.ebuild,v 1.1 2010/07/28 22:55:50 flameeyes Exp $
+
+EAPI=2
+
+# None of the three actually has working tests, but they should all work
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generate Ruby style object ids"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test
+
+#ruby_add_bdepend "test? ( dev-ruby/tryouts:0 )"
+
+#SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+#S="${WORKDIR}/delano-${PN}-*"
+
+each_ruby_test() {
+ ${RUBY} -S sergeant || die "tests failed"
+}