summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/childprocess/childprocess-0.3.5.ebuild')
-rw-r--r--dev-ruby/childprocess/childprocess-0.3.5.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-ruby/childprocess/childprocess-0.3.5.ebuild b/dev-ruby/childprocess/childprocess-0.3.5.ebuild
deleted file mode 100644
index 340ad35b7e19..000000000000
--- a/dev-ruby/childprocess/childprocess-0.3.5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/childprocess-0.3.5.ebuild,v 1.3 2012/10/28 17:48:27 armin76 Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A simple and reliable solution for controlling external programs running in the background."
-HOMEPAGE="https://github.com/jarib/childprocess"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:2 )"
-
-ruby_add_rdepend "virtual/ruby-ffi"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e "/[Bb]undler/d" Rakefile || die
-
- sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-}