summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activerecord/activerecord-1.8.0.ebuild')
-rw-r--r--dev-ruby/activerecord/activerecord-1.8.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/activerecord/activerecord-1.8.0.ebuild b/dev-ruby/activerecord/activerecord-1.8.0.ebuild
new file mode 100644
index 000000000000..7394fa0d3e8e
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-1.8.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-1.8.0.ebuild,v 1.1 2005/03/11 02:05:32 pythonhead Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+# The URL depends implicitly on the version, unfortunately. Even if you
+# change the filename on the end, it still downloads the same file.
+SRC_URI="http://rubyforge.org/frs/download.php/3326/${P}.gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="=dev-lang/ruby-1.8*
+ >=dev-ruby/activesupport-1.0.1"
+
+src_test() {
+ echo "Skipping rake test. It requires setting up live databases"
+ echo "and is beyond the scope of portage testing."
+}
+