summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-docs/python-docs-2.6.2.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-2.6.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-2.6.2.ebuild b/dev-python/python-docs/python-docs-2.6.2.ebuild
new file mode 100644
index 000000000000..96a5d99edb73
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.6.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.2.ebuild,v 1.1 2009/04/18 20:06:12 arfrever Exp $
+
+EAPI="2"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${D}/usr/share/doc/${PF}/html"
+}
+
+pkg_preinst() {
+ dodir /etc/env.d
+ echo "PYTHONDOCS=/usr/share/doc/${PF}/html/library" > "${D}/etc/env.d/50python-docs"
+}