summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysqlite/pysqlite-2.0.2.ebuild')
-rw-r--r--dev-python/pysqlite/pysqlite-2.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pysqlite/pysqlite-2.0.2.ebuild b/dev-python/pysqlite/pysqlite-2.0.2.ebuild
new file mode 100644
index 000000000000..5bcfc0f184ea
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.0.2.ebuild,v 1.1 2005/05/26 16:10:58 fserb Exp $
+
+inherit distutils
+
+IUSE="doc"
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="http://initd.org/pub/software/pysqlite/releases/${PV:0:3}/${PV}/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://initd.org/tracker/pysqlite/"
+
+KEYWORDS="~x86 ~sparc ~amd64"
+LICENSE="pysqlite"
+SLOT="2"
+
+DEPEND="virtual/python
+ >=dev-db/sqlite-3.1"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:data_files = data_files,:data_files = [],:" ${S}/setup.py
+}
+
+src_install() {
+ distutils_src_install
+ # Need to do the examples explicitly since dodoc
+ # doesn't do directories properly
+ if use doc ; then
+ cp -r ${S}/doc/*.{html,txt,css} ${D}/usr/share/doc/${PF} || die
+ dodir /usr/share/doc/${PF}/code || die
+ cp -r ${S}/doc/code/* ${D}/usr/share/doc/${PF}/code || die
+ fi
+}