summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygtkglext/pygtkglext-1.0.1.ebuild')
-rw-r--r--dev-python/pygtkglext/pygtkglext-1.0.1.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild b/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
index 3af32d1fce9c..5e4a882f1d3a 100644
--- a/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
+++ b/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild,v 1.1 2003/12/06 13:43:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild,v 1.2 2004/01/04 15:25:34 liquidx Exp $
+
+inherit python
DESCRIPTION="Python bindings to GtkGLExt"
HOMEPAGE="http://gtkglext.sourceforge.net/"
SRC_URI="mirror://sourceforge/gtkglext/${P}.tar.bz2"
-LICENSE="LGPL-2.1 GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-
-DEPEND=">=dev-lang/python-2.2
+DEPEND=">=dev-lang/python-2.2.3-r3
>=dev-python/pygtk-2
>=dev-libs/glib-2.0
>=x11-libs/gtk+-2.0
@@ -22,20 +23,22 @@ DEPEND=">=dev-lang/python-2.2
virtual/glu"
src_compile() {
-
- # ugly hack for sandbox (opens file readwrite, but only really reads)
- addwrite /usr/share/pygtk/2.0/codegen
-
econf
emake || die
-
}
src_install() {
-
make DESTDIR=${D} install || die
dodoc README COPYING* AUTHORS ChangeLog
insinto /usr/share/doc/${PF}/examples
doins examples/*.py
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-2.0
+}
+pkg_postrm() {
+ python_mod_cleanup
}