summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/arrayterator/arrayterator-1.0.1.ebuild')
-rw-r--r--dev-python/arrayterator/arrayterator-1.0.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/arrayterator/arrayterator-1.0.1.ebuild b/dev-python/arrayterator/arrayterator-1.0.1.ebuild
index cfa729819f8d..ec99c10cea14 100644
--- a/dev-python/arrayterator/arrayterator-1.0.1.ebuild
+++ b/dev-python/arrayterator/arrayterator-1.0.1.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/arrayterator-1.0.1.ebuild,v 1.2 2009/09/08 17:12:56 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/arrayterator-1.0.1.ebuild,v 1.3 2010/07/09 22:20:03 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="This class creates a buffered iterator for reading big arrays in small contiguous blocks."
HOMEPAGE="http://pypi.python.org/pypi/arrayterator"
-SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -18,8 +20,9 @@ IUSE=""
RDEPEND=">=dev-python/numpy-1.0_rc1"
DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6_rc3"
-RESTRICT_PYTHON_ABIS="3.*"
+ dev-python/setuptools"
+
+PYTHON_MODNAME="arrayterator.py"
src_test() {
cd tests
@@ -29,7 +32,3 @@ src_test() {
}
python_execute_function testing
}
-
-pkg_postinst() {
- python_mod_optimize arrayterator.py
-}