summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5/ZendFramework/ZendFramework-1.5.3.ebuild')
-rw-r--r--dev-php5/ZendFramework/ZendFramework-1.5.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-php5/ZendFramework/ZendFramework-1.5.3.ebuild b/dev-php5/ZendFramework/ZendFramework-1.5.3.ebuild
new file mode 100644
index 000000000000..5ccbe546d26b
--- /dev/null
+++ b/dev-php5/ZendFramework/ZendFramework-1.5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ZendFramework-1.5.3.ebuild,v 1.1 2008/08/08 17:10:45 gurligebis Exp $
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications."
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="http://framework.zend.com/releases/${P}/${P}.tar.gz
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+need_php_by_category
+
+src_install() {
+ php-lib-r1_src_install library/Zend $(cd library/Zend ; find . -type f -print)
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos
+ fi
+
+ dodoc README.txt
+ if use doc ; then
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ elog "For more info, please take a look at the manual at:"
+ elog "http://framework.zend.com/manual"
+}