summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-gd/cl-gd-0.2.0.ebuild')
-rw-r--r--dev-lisp/cl-gd/cl-gd-0.2.0.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-lisp/cl-gd/cl-gd-0.2.0.ebuild b/dev-lisp/cl-gd/cl-gd-0.2.0.ebuild
index 3af886e6f076..026386b21ace 100644
--- a/dev-lisp/cl-gd/cl-gd-0.2.0.ebuild
+++ b/dev-lisp/cl-gd/cl-gd-0.2.0.ebuild
@@ -1,30 +1,29 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-gd/cl-gd-0.2.0.ebuild,v 1.3 2004/06/24 23:43:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-gd/cl-gd-0.2.0.ebuild,v 1.4 2004/06/30 17:16:54 vapier Exp $
inherit common-lisp
DESCRIPTION="CL-GD is a library for Common Lisp which provides an interface to the GD Graphics Library for the dynamic creation of images. It is based on UFFI and should thus be portable to all CL implementations supported by UFFI."
-HOMEPAGE="http://weitz.de/cl-gd
- http://www.cliki.net/cl-gd"
+HOMEPAGE="http://weitz.de/cl-gd http://www.cliki.net/cl-gd"
SRC_URI="mirror://gentoo/${PN}_${PV}.orig.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
>=dev-lisp/cl-uffi-1.3.4
media-libs/libpng
media-libs/jpeg
media-libs/freetype
- >=media-libs/libgd-2.0.15
+ >=media-libs/gd-2.0.15
sys-libs/zlib
virtual/commonlisp"
CLPACKAGE=cl-gd
-S=${WORKDIR}/${P}
-
src_compile() {
gcc ${CFLAGS} -fPIC -c cl-gd-glue.c
ld -lgd -lz -lpng -ljpeg -lfreetype -lm -shared cl-gd-glue.o -o cl-gd-glue.so