summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/yaz/yaz-2.1.8.ebuild')
-rw-r--r--dev-libs/yaz/yaz-2.1.8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/yaz/yaz-2.1.8.ebuild b/dev-libs/yaz/yaz-2.1.8.ebuild
new file mode 100644
index 000000000000..6de0df1768f2
--- /dev/null
+++ b/dev-libs/yaz/yaz-2.1.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-2.1.8.ebuild,v 1.1 2005/07/03 18:26:33 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/${PN}"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="YAZ"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64 ~mips"
+IUSE="tcpd"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/openssl
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd
+ app-text/docbook-dsssl-stylesheets
+ app-text/docbook-xsl-stylesheets
+ dev-util/pkgconfig
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ local myopts
+ myopts="${myopts} `use_enable tcpd tcpd /usr`"
+
+ econf ${myopts} \
+ --enable-shared \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}