summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/poppler-qt3/poppler-qt3-0.10.6.ebuild')
-rw-r--r--dev-libs/poppler-qt3/poppler-qt3-0.10.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/poppler-qt3/poppler-qt3-0.10.6.ebuild b/dev-libs/poppler-qt3/poppler-qt3-0.10.6.ebuild
new file mode 100644
index 000000000000..f8f60d331eee
--- /dev/null
+++ b/dev-libs/poppler-qt3/poppler-qt3-0.10.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/poppler-qt3/poppler-qt3-0.10.6.ebuild,v 1.1 2009/04/16 23:24:47 loki_val Exp $
+
+EAPI=2
+
+POPPLER_MODULE=qt
+POPPLER_PKGCONFIG=poppler-qt.pc
+POPPLER_CONF="--enable-poppler-qt"
+
+inherit qt3 poppler
+
+DESCRIPTION="Qt3 bindings for poppler"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ ~dev-libs/poppler-${PV}
+ >=x11-libs/qt-3.3:3
+ "
+DEPEND="
+ ${RDEPEND}
+ "
+
+src_compile() {
+ poppler_src_compile POPPLER_QT_LIBS="$(pkg-config --libs qt-mt)"
+}