summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gauche/gauche-0.8.6.ebuild')
-rw-r--r--dev-lang/gauche/gauche-0.8.6.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-lang/gauche/gauche-0.8.6.ebuild b/dev-lang/gauche/gauche-0.8.6.ebuild
new file mode 100644
index 000000000000..ae293c156f67
--- /dev/null
+++ b/dev-lang/gauche/gauche-0.8.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/gauche-0.8.6.ebuild,v 1.1 2005/11/13 08:23:35 hattya Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="ipv6"
+
+MY_P="${P/g/G}"
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://gauche.sf.net/"
+SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=sys-libs/gdbm-1.8.0"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gdbm-gentoo.diff
+ epatch ${FILESDIR}/${PN}-gauche.m4-cc.diff
+ autoconf
+
+}
+
+src_compile() {
+
+ local myconf="--enable-threads=pthreads --enable-multibyte=utf8"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ strip-flags
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_test() {
+
+ make -s check || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL INSTALL.eucjp README
+
+}
+
+pkg_postinst() {
+
+ echo
+ ewarn "As of version 0.8.6, Gauche switched the default character"
+ ewarn "encoding from euc-jp to utf-8."
+ echo
+
+}