summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/velocity/velocity-1.4.ebuild')
-rw-r--r--dev-java/velocity/velocity-1.4.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-java/velocity/velocity-1.4.ebuild b/dev-java/velocity/velocity-1.4.ebuild
index 5ed4abea045e..19ce74d7800f 100644
--- a/dev-java/velocity/velocity-1.4.ebuild
+++ b/dev-java/velocity/velocity-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.4.ebuild,v 1.2 2004/07/30 18:44:33 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.4.ebuild,v 1.3 2004/08/02 15:48:49 axxo Exp $
DESCRIPTION="A Java-based template engine that allows easy creation/rendering of documents that format and present data."
HOMEPAGE="http://jakarta.apache.org/velocity/"
@@ -11,8 +11,8 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="doc j2ee jikes junit"
-DEPEND=">=dev-java/sun-jdk-1.3.1"
-RDEPEND=">=dev-java/sun-jdk-1.3.1
+DEPEND=">=virtual/jdk-1.3.1"
+RDEPEND=">=virtual/jdk-1.3.1
>=dev-java/ant-1.5.1
>=dev-java/avalon-logkit-bin-1.2
>=dev-java/oro-2.0.6
@@ -24,16 +24,16 @@ src_compile () {
local antflags
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use junit && antflags="${antflags} test"
+ use doc && antflags="${antflags} javadoc"
if use j2ee ; then
cp /opt/sun-j2ee-1.3.1/lib/j2ee.jar ${S}/build/lib
ant ${antflags} jar-J2EE || die "Java compile failed."
else
ant ${antflags} jar || die "Java compile failed"
fi
-
- use doc && ant javadocs || die "Document compile failed"
}
+
src_install () {
cd ${S}
if use j2ee ; then