summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimspell/ChangeLog7
-rw-r--r--app-vim/vimspell/Manifest4
-rw-r--r--app-vim/vimspell/files/digest-vimspell-1.841
-rw-r--r--app-vim/vimspell/vimspell-1.84.ebuild57
4 files changed, 67 insertions, 2 deletions
diff --git a/app-vim/vimspell/ChangeLog b/app-vim/vimspell/ChangeLog
index 497985fb6159..b0cf3b925525 100644
--- a/app-vim/vimspell/ChangeLog
+++ b/app-vim/vimspell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/vimspell
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimspell/ChangeLog,v 1.6 2004/04/21 19:02:59 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimspell/ChangeLog,v 1.7 2004/04/22 16:07:50 ciaranm Exp $
+
+*vimspell-1.84 (22 Apr 2004)
+
+ 22 Apr 2004; Ciaran McCreesh <ciaranm@gentoo.org> +vimspell-1.84.ebuild:
+ Version bump, hopefully fixes #48622
*vimspell-1.83 (21 Apr 2004)
diff --git a/app-vim/vimspell/Manifest b/app-vim/vimspell/Manifest
index a30f534d2502..b1b8cd658cc5 100644
--- a/app-vim/vimspell/Manifest
+++ b/app-vim/vimspell/Manifest
@@ -1,8 +1,10 @@
-MD5 8c675a1bac0160e571ac329b4b25be20 ChangeLog 876
+MD5 ad3fb7d3631968b9e20f00f6b5d0c32a ChangeLog 1021
+MD5 7016f1080e5da1a3923b9b8c5c5f50a0 vimspell-1.84.ebuild 2308
MD5 5603cc99f3e3662f1c0fc36cab5e5ee6 vimspell-1.70.ebuild 2299
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
MD5 9c6a5eb080dbde4bd361c73b81467ec0 vimspell-1.83.ebuild 2308
MD5 8708cffc2b7dba8962671807573f8206 vimspell-1.68.ebuild 2283
+MD5 7101dd811b1925b8c3eb3c8544a289c0 files/digest-vimspell-1.84 65
MD5 6a4ee637c8498ba26e82c61844aa5e55 files/digest-vimspell-1.70 65
MD5 1dd714afbfe6a2c4fa057c7402ed0388 files/digest-vimspell-1.83 65
MD5 584de3c97924b0422303af4e46df9a0d files/digest-vimspell-1.68 65
diff --git a/app-vim/vimspell/files/digest-vimspell-1.84 b/app-vim/vimspell/files/digest-vimspell-1.84
new file mode 100644
index 000000000000..bd1cfe60788b
--- /dev/null
+++ b/app-vim/vimspell/files/digest-vimspell-1.84
@@ -0,0 +1 @@
+MD5 7f3a6de67f1e09f5a77743015bc8e83e vimspell-1.84.tar.bz2 17841
diff --git a/app-vim/vimspell/vimspell-1.84.ebuild b/app-vim/vimspell/vimspell-1.84.ebuild
new file mode 100644
index 000000000000..2b320ef1a029
--- /dev/null
+++ b/app-vim/vimspell/vimspell-1.84.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimspell/vimspell-1.84.ebuild,v 1.1 2004/04/22 16:07:50 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: on-the-fly spell checking with aspell"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=465"
+LICENSE="GPL-1 | GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha ~ia64 ~ppc ~amd64"
+
+# In theory, this plugin supports either aspell or ispell. However,
+# virtual/spell has been removed by seemant in favour of just using
+# app-text/aspell:
+# 20:06 <@seemant> ciaranm: I think I might have removed it, come to
+# think of it, because I was on a kick to get everything converted
+# to aspell instead of ispell
+# 20:06 <@seemant> for the simple reason that ispell blows dogs
+# So we'll just force people to use aspell...
+RDEPEND="$RDEPEND app-text/aspell"
+
+function src_unpack() {
+ unpack ${A}
+ cd ${S}/plugin
+
+ # This plugin needs to be told which spell program to use. The default
+ # is hard-coded as 'ispell' in the plugin file. We can fix that with a
+ # bit of sed magic.
+ OLD_DEFAULT='s:SpellGetOption("spell_executable","ispell")'
+ NEW_DEFAULT='s:SpellGetOption("spell_executable","aspell")'
+ sed -e "s/$OLD_DEFAULT/$NEW_DEFAULT/g" \
+ -i vimspell.vim || die "default setting fix failed"
+
+ # This plugin also tries to install its own documentation automatically
+ # upon load. This breaks emerge unmerge, so we'll install the docs
+ # manually.
+ mkdir ${S}/doc || die
+ cd ${S}/doc
+ cp ${S}/plugin/vimspell.vim vimspell.txt
+
+ sed -e "1,/^=== \+START_DOC/d" \
+ -e "/^=== \+END_DOC/,\$d" \
+ -e "s/{{{[1-9]/ /g" \
+ -e "s/#version#/v${PV}/g" \
+ -i vimspell.txt || die "docs failed"
+ echo -ne "\n vim:tw=78:ts=8:ft=help:norl:\n" >> vimspell.txt
+
+ # Unfortunately, there's a rather large logic error in the documentation
+ # installation code. If vim can't write to /usr/share/vim/vimfiles/doc/
+ # then the plugin will try to install a copy of the docs locally, even if
+ # the global directory has an up-to-date copy. To get around this we'll
+ # make the SpellInstallDocumentation function do nothing.
+ cd ${S}/plugin
+ sed -e "/^function! s:SpellInstallDocumentation/a\ return 0" \
+ -i vimspell.vim || die "install fix failed"
+}
+