summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libwpg/libwpg-0.2.1.ebuild')
-rw-r--r--app-text/libwpg/libwpg-0.2.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/app-text/libwpg/libwpg-0.2.1.ebuild b/app-text/libwpg/libwpg-0.2.1.ebuild
deleted file mode 100644
index ba1f9d4dfd74..000000000000
--- a/app-text/libwpg/libwpg-0.2.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libwpg/libwpg-0.2.1.ebuild,v 1.9 2012/08/05 21:02:39 blueness Exp $
-
-EAPI=4
-
-inherit alternatives
-
-DESCRIPTION="C++ library to read and parse graphics in WPG"
-HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0.2"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc static-libs"
-
-RDEPEND="app-text/libwpd:0.9[tools]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-RDEPEND="${RDEPEND}
- !<app-text/libwpd-0.1.3-r1"
-
-src_configure() {
- econf \
- --disable-werror \
- --program-suffix=-${SLOT} \
- --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
- $(use_with doc docs) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete
-}
-
-pkg_postinst() {
- alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]" fi
-}
-
-pkg_postrm() {
- alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
-}