summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/ifuse/ifuse-1.1.2.ebuild')
-rw-r--r--app-pda/ifuse/ifuse-1.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-pda/ifuse/ifuse-1.1.2.ebuild b/app-pda/ifuse/ifuse-1.1.2.ebuild
new file mode 100644
index 000000000000..ffde0e4815e8
--- /dev/null
+++ b/app-pda/ifuse/ifuse-1.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/ifuse/ifuse-1.1.2.ebuild,v 1.1 2012/05/16 01:12:08 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="Mount Apple iPhone/iPod Touch file systems for backup purposes"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.1.4
+ >=app-pda/libplist-1.8
+ >=sys-fs/fuse-2.7.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+pkg_postinst() {
+ ewarn "Only use this filesystem driver to create backups of your data."
+ ewarn "The music database is hashed, and attempting to add files will "
+ ewarn "cause the iPod/iPhone to consider your database unauthorised."
+ ewarn "It will respond by wiping all media files, requiring a restore "
+ ewarn "through iTunes. You have been warned."
+}