summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/gnokii/files')
-rw-r--r--app-mobilephone/gnokii/files/digest-gnokii-0.6.122
-rw-r--r--app-mobilephone/gnokii/files/digest-gnokii-0.6.143
-rw-r--r--app-mobilephone/gnokii/files/gnokii-0.6.14-configure.in.patch159
3 files changed, 164 insertions, 0 deletions
diff --git a/app-mobilephone/gnokii/files/digest-gnokii-0.6.12 b/app-mobilephone/gnokii/files/digest-gnokii-0.6.12
index 4e3f7be5c775..1d1c9cffcd05 100644
--- a/app-mobilephone/gnokii/files/digest-gnokii-0.6.12
+++ b/app-mobilephone/gnokii/files/digest-gnokii-0.6.12
@@ -1 +1,3 @@
MD5 846e03e7cf3581000c9d0141c2950b79 gnokii-0.6.12.tar.bz2 1517318
+RMD160 98c1d4933455e6c05f460a0c59716baef3b0b83b gnokii-0.6.12.tar.bz2 1517318
+SHA256 7ec179f8d933c1005af2b4996198fffc10b528f4604b796c471d6413cc825b58 gnokii-0.6.12.tar.bz2 1517318
diff --git a/app-mobilephone/gnokii/files/digest-gnokii-0.6.14 b/app-mobilephone/gnokii/files/digest-gnokii-0.6.14
new file mode 100644
index 000000000000..2f801c789991
--- /dev/null
+++ b/app-mobilephone/gnokii/files/digest-gnokii-0.6.14
@@ -0,0 +1,3 @@
+MD5 89449d613c7a7e765a0d8da57ef1bb88 gnokii-0.6.14.tar.bz2 1546845
+RMD160 471689e6ccbb2a81c0eb27a073e27f88ed71e3df gnokii-0.6.14.tar.bz2 1546845
+SHA256 cea63cddf79864d306198c7a84091af0b4685816b352ae253a3e2bfac5e67cb7 gnokii-0.6.14.tar.bz2 1546845
diff --git a/app-mobilephone/gnokii/files/gnokii-0.6.14-configure.in.patch b/app-mobilephone/gnokii/files/gnokii-0.6.14-configure.in.patch
new file mode 100644
index 000000000000..28efeb044647
--- /dev/null
+++ b/app-mobilephone/gnokii/files/gnokii-0.6.14-configure.in.patch
@@ -0,0 +1,159 @@
+--- configure.in 2006-08-28 00:36:54.000000000 +0200
++++ configure.in.new 2006-09-12 09:23:52.000000000 +0200
+@@ -27,6 +27,105 @@
+ AC_PROG_LIBTOOL
+ AC_PROG_INSTALL
+
++dnl Copyright (C) 2003 Free Software Foundation, Inc.
++dnl This file is free software, distributed under the terms of the GNU
++dnl General Public License. As a special exception to the GNU General
++dnl Public License, this file may be distributed as part of a program
++dnl that contains a configuration script generated by Autoconf, under
++dnl the same distribution terms as the rest of that program.
++
++dnl From Bruno Haible.
++
++dnl Support for relocateble programs.
++AC_DEFUN([AC_RELOCATABLE],
++[
++ AC_REQUIRE([AC_PROG_INSTALL])
++ AC_BEFORE([AC_PROG_INSTALL],[AC_RELOCATABLE])
++ AC_REQUIRE([AC_LIB_LIBPATH])
++ AC_REQUIRE([AC_RELOCATABLE_LIBRARY])
++ use_elf_origin_trick=no
++ if test $RELOCATABLE = yes; then
++ # --enable-relocatable implies --disable-rpath
++ enable_rpath=no
++ AC_LIBOBJ([relocatable])
++ AC_DEFINE([ENABLE_RELOCATABLE], 1,
++ [Define to 1 if the package shall run at any location in the filesystem.])
++ case "$host_os" in
++ linux*) use_elf_origin_trick=yes ;;
++ esac
++ if test $use_elf_origin_trick = yes; then
++ dnl Use the dynamic linker's support for relocatable programs.
++ case "$ac_aux_dir" in
++ /*) reloc_ldflags="$ac_aux_dir/reloc-ldflags" ;;
++ *) reloc_ldflags="\$(top_builddir)/$ac_aux_dir/reloc-ldflags" ;;
++ esac
++ SET_RELOCATABLE="RELOCATABLE_LDFLAGS = \"$reloc_ldflags\" \"@host@\" \"\$(RELOCATABLE_LIBRARY_PATH)\""
++ else
++ dnl Unfortunately we cannot define INSTALL_PROGRAM to a command
++ dnl consisting of more than one word - libtool doesn't support this.
++ dnl So we abuse the INSTALL_PROGRAM_ENV hook, originally meant for the
++ dnl 'install-strip' target.
++ SET_RELOCATABLE="INSTALL_PROGRAM_ENV = RELOC_LIBRARY_PATH_VAR=\"$shlibpath_var\" RELOC_LIBRARY_PATH_VALUE=\"\$(RELOCATABLE_LIBRARY_PATH)\" RELOC_PREFIX=\"\$(prefix)\" RELOC_COMPILE_COMMAND=\"\$(CC) \$(CPPFLAGS) \$(CFLAGS) \$(LDFLAGS)\" RELOC_SRCDIR=\"\$(RELOCATABLE_SRC_DIR)\" RELOC_BUILDDIR=\"\$(RELOCATABLE_BUILD_DIR)\" RELOC_CONFIG_H_DIR=\"\$(RELOCATABLE_CONFIG_H_DIR)\" RELOC_INSTALL_PROG=\"$INSTALL_PROGRAM\""
++ case "$ac_aux_dir" in
++ /*) INSTALL_PROGRAM="$ac_aux_dir/install-reloc" ;;
++ *) INSTALL_PROGRAM="\$(top_builddir)/$ac_aux_dir/install-reloc" ;;
++ esac
++ fi
++ else
++ SET_RELOCATABLE=
++ fi
++ AC_SUBST([SET_RELOCATABLE])
++ AM_CONDITIONAL([RELOCATABLE_VIA_LD],
++ [test $use_elf_origin_trick = yes])
++])
++
++dnl Support for relocatable libraries.
++AC_DEFUN([AC_RELOCATABLE_LIBRARY],
++[
++ AC_REQUIRE([AC_RELOCATABLE_NOP])
++ dnl Easier to put this here once, instead of into the DEFS of each Makefile.
++ if test "X$prefix" = "XNONE"; then
++ reloc_final_prefix="$ac_default_prefix"
++ else
++ reloc_final_prefix="$prefix"
++ fi
++ AC_DEFINE_UNQUOTED([INSTALLPREFIX], ["${reloc_final_prefix}"],
++ [Define to the value of ${prefix}, as a string.])
++])
++
++dnl Support for relocatable packages for which it is a nop.
++AC_DEFUN([AC_RELOCATABLE_NOP],
++[
++ AC_MSG_CHECKING([whether to activate relocatable installation])
++ AC_ARG_ENABLE(relocatable,
++ [ --enable-relocatable install a package that can be moved in the filesystem],
++ [if test "$enableval" != no; then
++ RELOCATABLE=yes
++ else
++ RELOCATABLE=no
++ fi
++ ], RELOCATABLE=no)
++ AC_SUBST(RELOCATABLE)
++ AC_MSG_RESULT([$RELOCATABLE])
++])
++
++dnl Determine the platform dependent parameters needed to use relocatability:
++dnl shlibpath_var.
++AC_DEFUN([AC_LIB_LIBPATH],
++[
++ AC_REQUIRE([AC_LIB_PROG_LD]) dnl we use $LD
++ AC_REQUIRE([AC_CANONICAL_HOST]) dnl we use $host
++ AC_REQUIRE([AC_CONFIG_AUX_DIR_DEFAULT]) dnl we use $ac_aux_dir
++ AC_CACHE_CHECK([for shared library path variable], acl_cv_libpath, [
++ LD="$LD" \
++ ${CONFIG_SHELL-/bin/sh} "$ac_aux_dir/config.libpath" "$host" > conftest.sh
++ . ./conftest.sh
++ rm -f ./conftest.sh
++ acl_cv_libpath=${acl_cv_shlibpath_var:-none}
++ ])
++ shlibpath_var="$acl_cv_shlibpath_var"
++])
++
+ AC_RELOCATABLE
+
+ AM_ICONV
+@@ -250,6 +349,9 @@
+ )
+
+ USE_LIBICAL="no"
++AC_ARG_ENABLE(usb, AC_HELP_STRING([--enable-ical],
++[enable libical support (default is no)]),, [enable_ical=no])
++if test "$enable_ical" == "yes"; then
+ OLD_LIBS="$LIBS"
+ OLD_CFLAGS="$CFLAGS"
+ LIBS="$LIBS $ICAL_LIBS -lpthread -lical"
+@@ -282,22 +384,27 @@
+ CFLAGS="$OLD_CFLAGS"
+ ]
+ )
++fi
+
+ dnl ======================== Check for libusb
+ USE_LIBUSB="no"
+-AC_MSG_CHECKING(whether libusb is installed)
+-AC_TRY_COMPILE([#include <usb.h>],
+- [struct usb_dev_handle *dev;],
+- [
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([HAVE_LIBUSB],[1],[Use libusb])
+- USE_LIBUSB="yes"
+- LIBS="$LIBS -lusb"
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+-)
++AC_ARG_ENABLE(usb, AC_HELP_STRING([--enable-usb],
++[enable libusb support (default is no)]),, [enable_usb=no])
++if test "$enable_usb" == "yes"; then
++ AC_MSG_CHECKING(whether libusb is installed)
++ AC_TRY_COMPILE([#include <usb.h>],
++ [struct usb_dev_handle *dev;],
++ [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE([HAVE_LIBUSB],[1],[Use libusb])
++ USE_LIBUSB="yes"
++ LIBS="$LIBS -lusb"
++ ],
++ [
++ AC_MSG_RESULT(no)
++ ]
++ )
++fi
+
+ dnl ======================== Checks for gethostbyname support
+ AC_CHECK_FUNC(gethostbyname, ,