summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/evtest/evtest-1.30.ebuild')
-rw-r--r--app-misc/evtest/evtest-1.30.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/evtest/evtest-1.30.ebuild b/app-misc/evtest/evtest-1.30.ebuild
new file mode 100644
index 000000000000..5709e4c9f4e6
--- /dev/null
+++ b/app-misc/evtest/evtest-1.30.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/evtest/evtest-1.30.ebuild,v 1.1 2013/01/06 20:22:25 vapier Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="test program for capturing input device events"
+HOMEPAGE="http://cgit.freedesktop.org/evtest/"
+SRC_URI="http://cgit.freedesktop.org/evtest/snapshot/${PN}-${P}.tar.gz -> ${P}.tar.gz
+ mirror://gentoo/${P}-mans.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+xml"
+
+# We bundled the man pages ourselves to avoid xmlto/asciidoc.
+# We need libxml2 for the capture tool. While at runtime,
+# we have a file that can be used with xsltproc, we don't
+# directly need it ourselves, so don't depend on libxslt.
+# tar zcf ${P}-mans.tar.gz *.1 --transform=s:^:evtest-${P}/:
+RDEPEND="xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.30-autoconf.patch
+ epatch "${FILESDIR}"/${PN}-1.30-xml.patch
+ eautoreconf
+}
+
+src_configure() {
+ # We pre-compile the man pages.
+ XMLTO=/bin/true ASCIIDOC=/bin/true \
+ econf $(use_enable xml)
+}