summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/byobu/byobu-4.47.ebuild')
-rw-r--r--app-misc/byobu/byobu-4.47.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/byobu/byobu-4.47.ebuild b/app-misc/byobu/byobu-4.47.ebuild
new file mode 100644
index 000000000000..aad79784efe4
--- /dev/null
+++ b/app-misc/byobu/byobu-4.47.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-4.47.ebuild,v 1.1 2011/11/10 21:50:47 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="A set of profiles for the GNU Screen console window manager (app-misc/screen)"
+HOMEPAGE="https://launchpad.net/byobu"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-misc/screen app-misc/tmux )
+ dev-libs/newt"
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Create symlinks for backends
+ dosym ${PN} /usr/bin/${PN}-screen
+ dosym ${PN} /usr/bin/${PN}-tmux
+}