summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/thinkfan/files/thinkfan-0.7.3-makefile.patch')
-rw-r--r--app-laptop/thinkfan/files/thinkfan-0.7.3-makefile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/files/thinkfan-0.7.3-makefile.patch b/app-laptop/thinkfan/files/thinkfan-0.7.3-makefile.patch
new file mode 100644
index 000000000000..fac489464079
--- /dev/null
+++ b/app-laptop/thinkfan/files/thinkfan-0.7.3-makefile.patch
@@ -0,0 +1,28 @@
+--- thinkfan-0.7.3/Makefile
++++ thinkfan-0.7.3/Makefile
+@@ -1,20 +1,12 @@
+ .DEFAULT_GOAL := thinkfan
+
+-thinkfan: system.o parser.o config.o thinkfan.o message.o
+- gcc $(CFLAGS) -Wall -o thinkfan system.o config.o parser.o \
+- thinkfan.o message.o
+-
+-message.o: message.c globaldefs.h
+- gcc $(CFLAGS) -Wall -c message.c
++CC ?= gcc
+
+-system.o: system.c system.h message.h globaldefs.h parser.h
+- gcc $(CFLAGS) -Wall -c system.c
+-
+-config.o: config.c config.h message.h globaldefs.h system.h parser.h
+- gcc $(CFLAGS) -Wall -c config.c
++thinkfan: system.o parser.o config.o thinkfan.o message.o
++ $(CC) $(LDFLAGS) -Wall -o $@ $^
+
+-thinkfan.o: thinkfan.c thinkfan.h message.h globaldefs.h config.h
+- gcc $(CFLAGS) -Wall -c thinkfan.c
++%.o: %.c
++ $(CC) $(CFLAGS) -Wall -c -o $@ $<
+
+ clean:
+ rm -rf *.o thinkfan