summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-prime/scim-prime-0.2.1.ebuild')
-rw-r--r--app-i18n/scim-prime/scim-prime-0.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/scim-prime/scim-prime-0.2.1.ebuild b/app-i18n/scim-prime/scim-prime-0.2.1.ebuild
new file mode 100644
index 000000000000..20ddfc5905e5
--- /dev/null
+++ b/app-i18n/scim-prime/scim-prime-0.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-prime/scim-prime-0.2.1.ebuild,v 1.1 2005/04/24 16:11:44 usata Exp $
+
+DESCRIPTION="Japanese input method PRIME IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMPRIME"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/14378/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="|| ( >=app-i18n/scim-1.0 >=app-i18n/scim-cvs-1.0 )
+ >=app-i18n/prime-1.0.0"
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM with both GTK2 and XIM, you should use the following"
+ einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo
+}