summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qemu/qemu-0.5.2.ebuild')
-rw-r--r--app-emulation/qemu/qemu-0.5.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-emulation/qemu/qemu-0.5.2.ebuild b/app-emulation/qemu/qemu-0.5.2.ebuild
new file mode 100644
index 000000000000..399b591f8e6d
--- /dev/null
+++ b/app-emulation/qemu/qemu-0.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.5.2.ebuild,v 1.1 2004/01/28 03:55:56 zul Exp $
+
+DESCRIPTION="Multi-platform & multi-targets dynamic translator"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${P}.tar.gz"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+
+KEYWORDS="~x86 ~ppc -alpha -sparc -arm"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND="virtual/glibc
+ media-libs/libsdl"
+RDEPEND=""
+
+RESTRICT="nostrip"
+
+TARGET_LIST="arm-user i386-user i386-softmmu ppc-user sparc-user"
+
+src_compile () {
+ ./configure --prefix=/usr \
+ --target-list="${TARGET_LIST}" || die "could not configure"
+ make || die "make failed"
+}
+
+src_install() {
+ dobin qemu-mkcow
+ dodir /usr/share/qemu
+ insinto /usr/share/qemu
+ doins pc-bios/bios.bin pc-bios/vgabios.bin
+ doman qemu.1
+
+ dobin arm-user/qemu-arm
+ dobin i386-user/qemu-i386
+ dobin sparc-user/qemu-sparc
+ dobin ppc-user/qemu-ppc
+ dobin sparc-user/qemu-sparc
+
+ dobin i386-softmmu/qemu
+
+ dodoc README README.distrib *.html linux.sh
+}
+
+pkg_postinstall() {
+ echo ">> You will need the Universal TUN/TAP driver compiled into"
+ echo ">> kernel or as a module to use the virtual network device."
+}