summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-wiki/emacs-wiki-2.14.ebuild')
-rw-r--r--app-emacs/emacs-wiki/emacs-wiki-2.14.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/emacs-wiki/emacs-wiki-2.14.ebuild b/app-emacs/emacs-wiki/emacs-wiki-2.14.ebuild
new file mode 100644
index 000000000000..297944d73734
--- /dev/null
+++ b/app-emacs/emacs-wiki/emacs-wiki-2.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-wiki/emacs-wiki-2.14.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Maintain a local Wiki using Emacs-friendly markup"
+HOMEPAGE="ftp://ftp.cis.ohio-state.edu/pub/emacs-lisp/archive/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50emacs-wiki-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/emacs-wiki.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}