summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mousepad/mousepad-0.2.16.ebuild')
-rw-r--r--app-editors/mousepad/mousepad-0.2.16.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/app-editors/mousepad/mousepad-0.2.16.ebuild b/app-editors/mousepad/mousepad-0.2.16.ebuild
index 5aa06506948e..da41adfe3e43 100644
--- a/app-editors/mousepad/mousepad-0.2.16.ebuild
+++ b/app-editors/mousepad/mousepad-0.2.16.ebuild
@@ -1,24 +1,27 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mousepad/mousepad-0.2.16.ebuild,v 1.10 2009/07/27 17:35:02 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mousepad/mousepad-0.2.16.ebuild,v 1.11 2009/08/25 17:46:29 ssuominen Exp $
-EAPI=1
+EAPI=2
+inherit xfconf
-inherit xfce4
-
-XFCE_VERSION=4.6.0
-
-xfce4_core
-
-DESCRIPTION="Text editor"
+DESCRIPTION="A simple text editor for Xfce"
HOMEPAGE="http://www.xfce.org/projects/mousepad/"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
IUSE="debug"
RDEPEND=">=x11-libs/gtk+-2.6:2
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- >=xfce-base/libxfcegui4-${XFCE_VERSION}"
+ >=xfce-base/libxfcegui4-4.4"
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
dev-util/intltool"
-DOCS="AUTHORS ChangeLog NEWS README TODO"
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+}