summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/winex-doc/winex-doc-20020511.ebuild')
-rw-r--r--app-doc/winex-doc/winex-doc-20020511.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/app-doc/winex-doc/winex-doc-20020511.ebuild b/app-doc/winex-doc/winex-doc-20020511.ebuild
index 2fff13714e91..94d3d2ce1870 100644
--- a/app-doc/winex-doc/winex-doc-20020511.ebuild
+++ b/app-doc/winex-doc/winex-doc-20020511.ebuild
@@ -1,13 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/winex-doc/winex-doc-20020511.ebuild,v 1.2 2002/07/11 06:30:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/winex-doc/winex-doc-20020511.ebuild,v 1.3 2002/08/01 14:02:44 seemant Exp $
S=${WORKDIR}/wine
DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
SRC_URI="ftp:/www.ibiblio.org/gentoo/distfiles/winex-$PV.tar.bz2"
HOMEPAGE="http://www.transgaming.com/"
-DEPEND=""
+SLOT="0"
+LICENSE="Aladdin"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11"
src_compile() {
@@ -15,20 +19,18 @@ src_compile() {
local myconf
use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
- [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ [ -z $DEBUG ] && myconf="${myconf} --disable-trace --disable-debug" || myconf="${myconf} --enable-trace --enable-debug"
# there's no configure flag for cups, it's supposed to be autodetected
# the folks at #winehq were really angry about custom optimization
export CFLAGS=""
export CXXFLAGS=""
- ./configure --prefix=/usr \
- --exec_prefix=/usr/winex \
- --sysconfdir=/etc/winex \
- --mandir=/usr/winex/man \
- --host=${CHOST} \
- --enable-curses \
- ${myconf} || die
+ econf \
+ --exec_prefix=/usr/winex \
+ --sysconfdir=/etc/winex \
+ --enable-curses \
+ ${myconf} || die
cd ${S}/programs/winetest
cp Makefile 1