summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild')
-rw-r--r--app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild
index 9302ccc13091..f29c06ff1ab5 100644
--- a/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild
+++ b/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild,v 1.1 2008/08/08 12:14:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild,v 1.2 2008/08/11 11:15:25 ulm Exp $
-inherit elisp-common
+inherit elisp-common eutils
DESCRIPTION="Casting SPELs in Lisp - A Comic Book (Emacs Lisp Edition)"
HOMEPAGE="http://code.google.com/p/casting-spels-emacs/"
@@ -18,6 +18,12 @@ DEPEND="app-arch/unzip"
S="${WORKDIR}/${PN}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ edos2unix *.txt html/*.html {lisp,test}/*.el || die "edos2unix failed"
+}
+
src_install() {
elisp-install ${PN} lisp/*.el || die "elisp-install failed"
dohtml -r html/. images || die "dohtml failed"