summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild')
-rw-r--r--app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild
new file mode 100644
index 000000000000..bf7c4608f769
--- /dev/null
+++ b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild,v 1.1 2008/09/14 12:08:53 ikelos Exp $
+
+EAPI="1"
+
+DESCRIPTION="Tables available for ophcrack"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="xpfast? ( mirror://sourceforge/ophcrack/tables_xp_free_fast.zip )
+ xpsmall? ( mirror://sourceforge/ophcrack/tables_xp_free_small.zip )
+ vistafree? ( mirror://sourceforge/ophcrack/tables_vista_free.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="+xpfast xpsmall +vistafree"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ for i in ${A};
+ do
+ table=${i#tables_}
+ table=${table%.zip}
+ mkdir "${S}/${table}"
+ cd "${S}/${table}"
+ unpack "${i}"
+ done
+}
+
+src_install() {
+ dodir /usr/share/ophcrack/
+ cp -r "${S}"/* "${D}/usr/share/ophcrack"
+}