summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unrar/unrar-3.7.8.ebuild')
-rw-r--r--app-arch/unrar/unrar-3.7.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/unrar/unrar-3.7.8.ebuild b/app-arch/unrar/unrar-3.7.8.ebuild
new file mode 100644
index 000000000000..dff9200ca876
--- /dev/null
+++ b/app-arch/unrar/unrar-3.7.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-3.7.8.ebuild,v 1.1 2007/09/22 18:12:37 vapier Exp $
+
+inherit toolchain-funcs
+
+MY_PN=${PN}src
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="http://www.rarlab.com/rar_add.htm"
+SRC_URI="http://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="unRAR"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="!app-arch/unrar-gpl"
+
+S=${WORKDIR}/unrar
+
+src_compile() {
+ emake \
+ -f makefile.unix \
+ CXXFLAGS="${CXXFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ STRIP="true" || die "emake failed"
+}
+
+src_install() {
+ dobin unrar || die "dobin failed"
+ dodoc readme.txt
+}