summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/guitar')
-rw-r--r--app-arch/guitar/files/install.gnome12
-rw-r--r--app-arch/guitar/guitar-0.1.4.ebuild5
2 files changed, 15 insertions, 2 deletions
diff --git a/app-arch/guitar/files/install.gnome b/app-arch/guitar/files/install.gnome
new file mode 100644
index 000000000000..0d3e7a1013f9
--- /dev/null
+++ b/app-arch/guitar/files/install.gnome
@@ -0,0 +1,12 @@
+
+if [ -e ./using_gnome ]; then
+ if [ "$1" = "uninstall" ]; then
+ rm ${D}/`gnome-config --prefix`/share/pixmaps/guiTAR.xpm
+ rm ${D}/`gnome-config --prefix`/share/gnome/apps/Utilities/guiTAR.desktop
+ else
+ ./mkinstalldirs ${D}/`gnome-config --prefix`/share/pixmaps
+ cp -f src/guiTAR.xpm ${D}/`gnome-config --prefix`/share/pixmaps/
+ ./mkinstalldirs ${D}/`gnome-config --prefix`/share/gnome/apps/Utilities
+ cp -f guiTAR.desktop ${D}/`gnome-config --prefix`/share/gnome/apps/Utilities/
+ fi
+fi
diff --git a/app-arch/guitar/guitar-0.1.4.ebuild b/app-arch/guitar/guitar-0.1.4.ebuild
index 64eaa72e6b67..1875fb833e61 100644
--- a/app-arch/guitar/guitar-0.1.4.ebuild
+++ b/app-arch/guitar/guitar-0.1.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: José Alberto Suárez López <bass@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-arch/guitar/guitar-0.1.4.ebuild,v 1.1 2002/05/20 22:56:46 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/guitar/guitar-0.1.4.ebuild,v 1.2 2002/05/25 23:17:09 bass Exp $
MY_P=guiTAR-${PV}
@@ -33,6 +33,7 @@ src_compile() {
}
src_install() {
-
+
+ use gnome && cp ${FILESDIR}/install.gnome ${S}
einstall || die
}