summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/tora/Manifest6
-rw-r--r--dev-db/tora/files/digest-tora-1.3.11-r21
-rw-r--r--dev-db/tora/files/digest-tora-1.3.121
-rw-r--r--dev-db/tora/files/tora-clipboard.patch86
-rw-r--r--dev-db/tora/files/tora-index-segfault.patch23
-rw-r--r--dev-db/tora/tora-1.3.11-r2.ebuild56
-rw-r--r--dev-db/tora/tora-1.3.12.ebuild49
7 files changed, 0 insertions, 222 deletions
diff --git a/dev-db/tora/Manifest b/dev-db/tora/Manifest
index 5608672cf5a9..d2050dd84977 100644
--- a/dev-db/tora/Manifest
+++ b/dev-db/tora/Manifest
@@ -1,10 +1,4 @@
-MD5 a8aedc75029cb331d7a19dc2fa6dc119 tora-1.3.11-r2.ebuild 1446
MD5 74dbe802ab7d2f4e3dc7a8bf203bc337 tora-1.3.13.ebuild 1526
-MD5 b84b18489e9f5cfd4d9a5bf57f544f96 tora-1.3.12.ebuild 1323
MD5 dfc5c96ea821d8d485aeb2a2850cce7e ChangeLog 3600
MD5 bda8803c4adc9cf0b308b71157891f05 metadata.xml 536
-MD5 0cb18bcf00a1bd7ccb4010bba81619ed files/tora-index-segfault.patch 619
-MD5 84d2b43252820fa856e99a318c853da8 files/tora-clipboard.patch 2146
-MD5 74ad78009cd80393e43affc569ee96da files/digest-tora-1.3.12 70
MD5 6e56617a37ef8382d8eda0609b63ea02 files/digest-tora-1.3.13 70
-MD5 6d41a4b9f78eb3b0b95c97281917205d files/digest-tora-1.3.11-r2 70
diff --git a/dev-db/tora/files/digest-tora-1.3.11-r2 b/dev-db/tora/files/digest-tora-1.3.11-r2
deleted file mode 100644
index d176267843c8..000000000000
--- a/dev-db/tora/files/digest-tora-1.3.11-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e056c5c84db1da8bccd7688a0aef9317 tora-alpha-1.3.11.tar.gz 2405314
diff --git a/dev-db/tora/files/digest-tora-1.3.12 b/dev-db/tora/files/digest-tora-1.3.12
deleted file mode 100644
index 2f18c0adae7a..000000000000
--- a/dev-db/tora/files/digest-tora-1.3.12
+++ /dev/null
@@ -1 +0,0 @@
-MD5 25f2f2bec72d1dad0b97c06d07cc287c tora-alpha-1.3.12.tar.gz 2407428
diff --git a/dev-db/tora/files/tora-clipboard.patch b/dev-db/tora/files/tora-clipboard.patch
deleted file mode 100644
index b7f3dfa4f9aa..000000000000
--- a/dev-db/tora/files/tora-clipboard.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-Index: qtlegacy/qtmultilineedit.cpp
-===================================================================
-RCS file: /cvsroot/tora/tora/qtlegacy/qtmultilineedit.cpp,v
-retrieving revision 1.6
-diff -u -r1.6 qtmultilineedit.cpp
---- qtlegacy/qtmultilineedit.cpp 24 Jul 2003 02:26:48 -0000 1.6
-+++ qtlegacy/qtmultilineedit.cpp 26 Aug 2003 08:34:32 -0000
-@@ -1348,7 +1348,7 @@
- case Key_Y:
- redo();
- break;
--#if defined (_WS_WIN_)
-+#if defined (Q_WS_WIN)
- case Key_Insert:
- copy();
- #endif
-@@ -1379,7 +1379,7 @@
- end( e->state() & ShiftButton );
- break;
- case Key_Delete:
--#if defined (_WS_WIN_)
-+#if defined (Q_WS_WIN)
- if ( e->state() & ShiftButton ) {
- cut();
- break;
-@@ -1401,7 +1401,7 @@
- case Key_Tab:
- insert( e->text() );
- break;
--#if defined (_WS_WIN_)
-+#if defined (Q_WS_WIN)
- case Key_Insert:
- if ( e->state() & ShiftButton )
- paste();
-@@ -2376,13 +2376,13 @@
- turnMark( FALSE );
-
- #ifndef QT_NO_CLIPBOARD
--#if defined(_WS_X11_)
-+#if defined(Q_WS_X11)
- else if ( echoMode() == Normal )
- copy();
- #endif
-
- if ( e->button() == MidButton && !readOnly ) {
--#if defined(_WS_X11_)
-+#if defined(Q_WS_X11)
- paste(); // Will repaint the cursor line.
- #else
- #ifndef QT_NO_COMPAT
-@@ -2845,7 +2845,7 @@
- turnMark( markDragX != markAnchorX || markDragY != markAnchorY );
-
- #ifndef QT_NO_CLIPBOARD
--#if defined(_WS_X11_)
-+#if defined(Q_WS_X11)
- if ( echoMode() == Normal )
- copy();
- #endif
-@@ -2876,7 +2876,7 @@
- {
- QString t = markedText();
- if ( !t.isEmpty() && echoMode() == Normal ) {
--#if defined(_WS_X11_)
-+#if defined(Q_WS_X11)
- disconnect( QApplication::clipboard(), SIGNAL(dataChanged()), this, 0);
- #endif
- #if defined(_OS_WIN32_)
-@@ -2924,7 +2924,7 @@
-
- void QtMultiLineEdit::clipboardChanged()
- {
--#if defined(_WS_X11_)
-+#if defined(Q_WS_X11)
- disconnect( QApplication::clipboard(), SIGNAL(dataChanged()),
- this, SLOT(clipboardChanged()) );
- turnMark( FALSE );
-@@ -4195,7 +4195,7 @@
- switch ( ke->key() ) {
- case Key_A:
- case Key_E:
--#if defined (_WS_WIN_)
-+#if defined (Q_WS_WIN)
- case Key_Insert:
- #endif
- case Key_X:
diff --git a/dev-db/tora/files/tora-index-segfault.patch b/dev-db/tora/files/tora-index-segfault.patch
deleted file mode 100644
index ffe663a870a2..000000000000
--- a/dev-db/tora/files/tora-index-segfault.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Index: tooracleconnection.cpp
-===================================================================
-RCS file: /cvsroot/tora/tora/tooracleconnection.cpp,v
-retrieving revision 1.80
-diff -u -r1.80 tooracleconnection.cpp
---- tooracleconnection.cpp 9 Aug 2003 13:36:17 -0000 1.80
-+++ tooracleconnection.cpp 10 Aug 2003 14:30:56 -0000
-@@ -202,11 +202,13 @@
- }
- virtual ~oracleQuery()
- {
-+ if(Query!=0) {
- #ifdef OTL_STREAM_POOLING_ON
-- if (!SaveInPool)
-+ if (!SaveInPool)
- Query->close(false);
- #endif
-- delete Query;
-+ delete Query;
-+ }
- }
- virtual void execute(void);
-
diff --git a/dev-db/tora/tora-1.3.11-r2.ebuild b/dev-db/tora/tora-1.3.11-r2.ebuild
deleted file mode 100644
index 46c212c98880..000000000000
--- a/dev-db/tora/tora-1.3.11-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.11-r2.ebuild,v 1.9 2004/01/22 21:57:03 rizzo Exp $
-
-IUSE="kde oci8"
-DESCRIPTION="TOra - Toolkit For Oracle"
-HOMEPAGE="http://www.globecom.se/tora/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
-
-DEPEND=">=x11-libs/qt-3.0.0
- dev-lang/perl
- kde? ( >=kde-base/kdelibs-3.1 )"
-
-pkg_setup() {
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- ewarn "ORACLE_HOME variable is not set."
- ewarn ""
- ewarn "You must install Oracle >= 8i client for Linux in"
- ewarn "order to compile TOra with Oracle support."
- ewarn ""
- ewarn "Otherwise specify -oci8 in your USE variable."
- ewarn ""
- ewarn "You can download the Oracle software from"
- ewarn "http://otn.oracle.com/software/content.html"
- die
- fi
-}
-
-src_unpack() {
- unpack ${PN}-alpha-${PV}.tar.gz
- cd ${P}
- epatch ${FILESDIR}/tora-index-segfault.patch
- epatch ${FILESDIR}/tora-clipboard.patch
-}
-
-src_compile() {
- local myconf
-
- use kde \
- && myconf="$myconf --with-kde" \
- || myconf="$myconf --without-kde"
- use oci8 || myconf="$myconf --without-oracle"
-
- ./configure --prefix=/usr --with-mono $myconf || die "conf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dodir ${D}/usr/bin
- einstall ROOT=${D}
- dodoc LICENSE.txt BUGS INSTALL NEWS README TODO
-}
diff --git a/dev-db/tora/tora-1.3.12.ebuild b/dev-db/tora/tora-1.3.12.ebuild
deleted file mode 100644
index 320cb120cb76..000000000000
--- a/dev-db/tora/tora-1.3.12.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.12.ebuild,v 1.5 2004/01/22 21:57:03 rizzo Exp $
-
-IUSE="kde oci8"
-DESCRIPTION="TOra - Toolkit For Oracle"
-HOMEPAGE="http://www.globecom.se/tora/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
-
-DEPEND=">=x11-libs/qt-3.0.0
- dev-lang/perl
- kde? ( >=kde-base/kdelibs-3.1 )"
-
-pkg_setup() {
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- ewarn "ORACLE_HOME variable is not set."
- ewarn ""
- ewarn "You must install Oracle >= 8i client for Linux in"
- ewarn "order to compile TOra with Oracle support."
- ewarn ""
- ewarn "Otherwise specify -oci8 in your USE variable."
- ewarn ""
- ewarn "You can download the Oracle software from"
- ewarn "http://otn.oracle.com/software/content.html"
- die
- fi
-}
-
-src_compile() {
- local myconf
-
- use kde \
- && myconf="$myconf --with-kde" \
- || myconf="$myconf --without-kde"
- use oci8 || myconf="$myconf --without-oracle"
-
- ./configure --prefix=/usr --with-mono $myconf || die "conf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dodir ${D}/usr/bin
- einstall ROOT=${D}
- dodoc LICENSE.txt BUGS INSTALL NEWS README TODO
-}