summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/guile/guile-1.4-r3.ebuild14
-rw-r--r--dev-util/guile/guile-1.4.1.ebuild25
-rw-r--r--dev-util/guile/guile-1.5.4.ebuild14
-rw-r--r--dev-util/injectso/injectso-0.2.ebuild21
4 files changed, 23 insertions, 51 deletions
diff --git a/dev-util/guile/guile-1.4-r3.ebuild b/dev-util/guile/guile-1.4-r3.ebuild
index c336db28edc9..9cb1b35b26ff 100644
--- a/dev-util/guile/guile-1.4-r3.ebuild
+++ b/dev-util/guile/guile-1.4-r3.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.4-r3.ebuild,v 1.11 2003/02/13 11:55:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.4-r3.ebuild,v 1.12 2003/04/23 16:41:42 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Guile is an interpreter for Scheme"
+DESCRIPTION="Scheme interpreter"
SRC_URI="ftp://prep.ai.mit.edu/gnu/guile/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/guile/"
@@ -16,22 +15,17 @@ DEPEND=">=sys-libs/ncurses-5.1
src_unpack() {
unpack ${A}
- cd ${S}
- cp ${FILESDIR}/net_db.c libguile/
+ cp ${FILESDIR}/net_db.c ${S}/libguile/
}
src_compile() {
-
econf \
--with-threads \
--with-modules || die
-
make || die
}
src_install() {
einstall || die
-
- dodoc AUTHORS COPYING ChangeLog GUILE-VERSION HACKING NEWS
- dodoc README SNAPSHOTS THANKS
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
}
diff --git a/dev-util/guile/guile-1.4.1.ebuild b/dev-util/guile/guile-1.4.1.ebuild
index 9712e4c2f24c..98dc4d7e29d7 100644
--- a/dev-util/guile/guile-1.4.1.ebuild
+++ b/dev-util/guile/guile-1.4.1.ebuild
@@ -1,45 +1,36 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.4.1.ebuild,v 1.8 2003/02/13 11:55:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.4.1.ebuild,v 1.9 2003/04/23 16:41:42 vapier Exp $
-inherit flag-o-matic || die "I lost my inheritance."
+inherit flag-o-matic
-S=${WORKDIR}/${P}
-DESCRIPTION="Guile is an interpreter for Scheme"
+DESCRIPTION="Scheme interpreter"
SRC_URI="mirror://gnu/guile/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/guile/"
SLOT="1.4.1"
LICENSE="GPL-2"
-KEYWORDS="x86 alpha ~ppc"
+KEYWORDS="x86 ~ppc alpha"
DEPEND=">=sys-libs/ncurses-5.1
>=sys-libs/readline-4.1"
-if [ "${ARCH}" == "ppc" ]
-then
- # guile-config breaks with -O3
- replace-flags -O3 -O2
-fi
+# guile-config breaks with -O3
+[ "${ARCH}" == "ppc" ] && replace-flags -O3 -O2
src_unpack() {
unpack ${A}
- cd ${S}
- cp ${FILESDIR}/net_db.c libguile/
+ cp ${FILESDIR}/net_db.c ${S}/libguile/
}
src_compile() {
-
econf \
--with-threads \
--with-modules || die "Configuration failed"
-
make || die "Compilation failed"
}
src_install() {
einstall || die "Installation failed"
-
- dodoc ANON-CVS AUTHORS COPYING ChangeLog HACKING NEWS README
- dodoc SNAPSHOTS THANKS
+ dodoc ANON-CVS AUTHORS ChangeLog HACKING NEWS README SNAPSHOTS THANKS
}
diff --git a/dev-util/guile/guile-1.5.4.ebuild b/dev-util/guile/guile-1.5.4.ebuild
index 9cac3bcdfe99..5d6d2fbdb653 100644
--- a/dev-util/guile/guile-1.5.4.ebuild
+++ b/dev-util/guile/guile-1.5.4.ebuild
@@ -1,32 +1,26 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.5.4.ebuild,v 1.8 2003/02/13 11:56:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.5.4.ebuild,v 1.9 2003/04/23 16:41:42 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Guile is an interpreter for Scheme"
+DESCRIPTION="Scheme interpreter"
SRC_URI="ftp://alpha.gnu.org/gnu/guile/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/guile/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="x86 ppc sparc"
DEPEND=">=sys-libs/ncurses-5.1
>=sys-libs/readline-4.1"
src_compile() {
-
econf \
--with-threads \
--with-modules || die
-
emake || die
}
src_install() {
-
einstall || die
-
- dodoc AUTHORS COPYING ChangeLog GUILE-VERSION HACKING NEWS
- dodoc README SNAPSHOTS THANKS
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
}
diff --git a/dev-util/injectso/injectso-0.2.ebuild b/dev-util/injectso/injectso-0.2.ebuild
index 912238fbbad2..aea990abcd6c 100644
--- a/dev-util/injectso/injectso-0.2.ebuild
+++ b/dev-util/injectso/injectso-0.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/injectso/injectso-0.2.ebuild,v 1.3 2003/02/13 11:56:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/injectso/injectso-0.2.ebuild,v 1.4 2003/04/23 16:42:29 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Inject shared libraries into running processes under Solaris and Linux"
HOMEPAGE="http://www.securereality.com.au/"
SRC_URI="http://www.securereality.com.au/archives/${P}.tar.gz"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
@@ -13,14 +13,11 @@ KEYWORDS="x86"
DEPEND="virtual/glibc"
src_compile() {
-
econf || die
emake || die
-
}
src_install() {
-
dobin injectso
dodir /usr/lib/injectso
@@ -29,16 +26,12 @@ src_install() {
dodoc ChangeLog README.txt
dohtml README.html
-
}
pkg_postinst() {
-
- einfo
- einfo Read the documentation for instructions on how to use this tool.
- einfo The sample library \"libtest.so\" and its source file \"libtest.c\"
- einfo be found in /usr/lib/injectso.
- einfo
-
+ echo
+ einfo "Read the documentation for instructions on how to use this tool."
+ einfo "The sample library \"libtest.so\" and its source file \"libtest.c\""
+ einfo "be found in /usr/lib/injectso."
+ echo
}
-