summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/alevt/alevt-1.6.0-r3.ebuild31
-rw-r--r--media-video/fame/fame-0.9.0.ebuild11
-rw-r--r--media-video/lumiere/lumiere-0.3.0.ebuild13
-rw-r--r--media-video/lumiere/lumiere-0.4.ebuild13
-rw-r--r--media-video/mtxdrivers-pro/mtxdrivers-pro-1.0_beta4.ebuild46
-rw-r--r--media-video/mtxdrivers/mtxdrivers-0.2.1.ebuild20
-rw-r--r--media-video/mtxdrivers/mtxdrivers-0.3.0.ebuild39
-rw-r--r--media-video/nvclock/nvclock-0.6.2-r1.ebuild21
-rw-r--r--media-video/quickrip/quickrip-0.4.ebuild37
-rw-r--r--media-video/quickrip/quickrip-0.5.ebuild35
-rw-r--r--media-video/quickrip/quickrip-0.6.ebuild33
-rw-r--r--media-video/quickrip/quickrip-0.7.ebuild9
-rw-r--r--media-video/recmpeg/recmpeg-1.0.5.ebuild11
-rw-r--r--media-video/usb-pwcx/usb-pwcx-8.2.2.ebuild12
-rw-r--r--media-video/vdr/vdr-1.1.27.ebuild13
-rw-r--r--media-video/w3cam/w3cam-0.7.2.ebuild23
-rw-r--r--media-video/yanc/yanc-0.2.0.ebuild18
17 files changed, 166 insertions, 219 deletions
diff --git a/media-video/alevt/alevt-1.6.0-r3.ebuild b/media-video/alevt/alevt-1.6.0-r3.ebuild
index 9d8bb30c8a92..6a74e23ccc03 100644
--- a/media-video/alevt/alevt-1.6.0-r3.ebuild
+++ b/media-video/alevt/alevt-1.6.0-r3.ebuild
@@ -1,48 +1,39 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/alevt-1.6.0-r3.ebuild,v 1.3 2003/02/13 13:22:37 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/alevt-1.6.0-r3.ebuild,v 1.4 2003/08/07 04:13:00 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="Teletext viewer for X11"
-SRC_URI="http://www.ibiblio.org/pub/Linux/apps/video/${P}.tar.gz"
HOMEPAGE="http://www.goron.de/~froese/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/video/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+LICENSE="GPL-2"
DEPEND="virtual/x11
>=media-libs/libpng-1.0.12"
-
-
-LICENSE="GPL-2"
src_unpack() {
-
unpack ${P}.tar.gz
- cd ${WORKDIR}
-
- # Parallel make patch
- patch -p0 < ${FILESDIR}/${P}-gentoo.diff
-
+ epatch ${FILESDIR}/${P}-gentoo.diff # Parallel make patch
}
src_compile() {
-
emake || die
-
}
-src_install () {
-
+src_install() {
dobin alevt alevt-cap alevt-date
doman alevt.1x alevt-date.1 alevt-cap.1
dodoc CHANGELOG COPYRIGHT README
- use gnome && ( \
+ if [ `use gnome` ] ; then
insinto /usr/share/pixmaps
newins contrib/mini-alevt.xpm alevt.xpm
insinto /usr/share/applications
doins ${FILESDIR}/alevt.desktop
- )
+ fi
}
diff --git a/media-video/fame/fame-0.9.0.ebuild b/media-video/fame/fame-0.9.0.ebuild
index 33e29ac620a3..12b89d162405 100644
--- a/media-video/fame/fame-0.9.0.ebuild
+++ b/media-video/fame/fame-0.9.0.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-video/fame/fame-0.9.0.ebuild,v 1.4 2003/07/12 21:12:38 aliz Exp $
-
-IUSE="mmx sse"
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/fame/fame-0.9.0.ebuild,v 1.5 2003/08/07 04:13:19 vapier Exp $
DESCRIPTION="fame is a multimedia encoder, which captures video from a video4linux device, and optionnaly sound, for MPEG encoding."
+HOMEPAGE="http://fame.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://fame.sourceforge.net"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE="mmx sse"
DEPEND="virtual/glibc
>=media-libs/libfame-0.9.0"
diff --git a/media-video/lumiere/lumiere-0.3.0.ebuild b/media-video/lumiere/lumiere-0.3.0.ebuild
index 27ac7eaa7d07..a619b3d950a2 100644
--- a/media-video/lumiere/lumiere-0.3.0.ebuild
+++ b/media-video/lumiere/lumiere-0.3.0.ebuild
@@ -1,26 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-video/lumiere/lumiere-0.3.0.ebuild,v 1.4 2003/07/12 21:12:48 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/lumiere/lumiere-0.3.0.ebuild,v 1.5 2003/08/07 04:13:59 vapier Exp $
inherit gnome2 debug
-SRC_URI="http://savannah.nongnu.org/download/${PN}/${PN}.pkg/0.3/${P}.tar.gz"
-
-IUSE=""
-S=${WORKDIR}/${P}
DESCRIPTION="gnome2 front-end for mplayer"
HOMEPAGE="http://www.nongnu.org/lumiere"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${PN}.pkg/0.3/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
RDEPEND="media-video/mplayer
gnome-base/nautilus"
-
DEPEND=">=dev-util/intltool-0.18
>=dev-util/pkgconfig-0.12.0
${RDEPEND}"
DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS README"
-
-
diff --git a/media-video/lumiere/lumiere-0.4.ebuild b/media-video/lumiere/lumiere-0.4.ebuild
index c85e83932d29..752f0464e5dc 100644
--- a/media-video/lumiere/lumiere-0.4.ebuild
+++ b/media-video/lumiere/lumiere-0.4.ebuild
@@ -1,22 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-video/lumiere/lumiere-0.4.ebuild,v 1.3 2003/07/12 21:12:49 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/lumiere/lumiere-0.4.ebuild,v 1.4 2003/08/07 04:13:59 vapier Exp $
inherit gnome2 debug
-SRC_URI="http://savannah.nongnu.org/download/${PN}/${PN}.pkg/${PV}/${P}.tar.gz"
-
-IUSE=""
-S=${WORKDIR}/${P}
DESCRIPTION="gnome2 front-end for mplayer"
HOMEPAGE="http://www.nongnu.org/lumiere"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${PN}.pkg/${PV}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
RDEPEND="media-video/mplayer
gnome-base/nautilus"
-
DEPEND=">=dev-util/intltool-0.18
>=dev-util/pkgconfig-0.12.0
>=x11-libs/gtkglarea-1.99.0
@@ -25,5 +22,3 @@ DEPEND=">=dev-util/intltool-0.18
${RDEPEND}"
DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS README"
-
-
diff --git a/media-video/mtxdrivers-pro/mtxdrivers-pro-1.0_beta4.ebuild b/media-video/mtxdrivers-pro/mtxdrivers-pro-1.0_beta4.ebuild
index 24c4252f7b92..0f3ed00326eb 100644
--- a/media-video/mtxdrivers-pro/mtxdrivers-pro-1.0_beta4.ebuild
+++ b/media-video/mtxdrivers-pro/mtxdrivers-pro-1.0_beta4.ebuild
@@ -1,41 +1,35 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers-pro/mtxdrivers-pro-1.0_beta4.ebuild,v 1.5 2003/06/06 20:24:33 prez Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers-pro/mtxdrivers-pro-1.0_beta4.ebuild,v 1.6 2003/08/07 04:21:37 vapier Exp $
At="mtxdrivers-pro-rh9.0-beta4.tar.gz"
S="${WORKDIR}/mtxdrivers-pro-RH9.0-beta4"
-SRC_URI=""
DESCRIPTION="Drviers for the Matrox Parhelia and Millenium P650/P750 cards with GL suport."
HOMEPAGE="http://www.matrox.com/mga/products/parhelia/home.cfm"
+SRC_URI="${At}"
+
+LICENSE="Matrox"
+SLOT="0"
+KEYWORDS="x86"
+RESTRICT="fetch"
DEPEND=">=x11-base/xfree-4.2.0
virtual/kernel
opengl-update
- !mtxdrivers"
-
-SLOT="0"
-LICENSE="Matrox"
-KEYWORDS="x86"
-PROVIDE="virtual/glibc"
+ !mtxdrivers"
Xversion=`X -version 2>&1 | grep -s "XFree86 Version" | cut -d" " -f3 | sed -e "s/\([^\.]*\.[^\.]*\.[^\.]*\)\.[^\.]*/\1/"`
GLversion="1.3.0"
-src_unpack() {
- if [ ! -f "${DISTDIR}/${At}" ]; then
- einfo "Matrox requires you email them for the 'pro' version of their drivers"
- einfo "(ie. the ones with GL support). If you do not need GL support, please"
- einfo "emerge mtxdrivers, otherwise e-mail cad-support@matrox.com and request"
- einfo "the Matrox Parhelia drivers with GL support. Please remember to"
- einfo "download the RH9.0 driver, once you are given the site address."
- die
- fi
- unpack ${At}
+pkg_nofetch() {
+ einfo "Matrox requires you email them for the 'pro' version of their drivers"
+ einfo "(ie. the ones with GL support). If you do not need GL support, please"
+ einfo "emerge mtxdrivers, otherwise e-mail cad-support@matrox.com and request"
+ einfo "the Matrox Parhelia drivers with GL support. Please remember to"
+ einfo "download the RH9.0 driver, once you are given the site address."
}
src_compile() {
- cd ${S}
-
if [ ! -e ${S}/xfree86/${Xversion} ]; then
eerror "Matrox does not support XFree v${Xversion}"
exit 1
@@ -51,15 +45,13 @@ src_compile() {
}
src_install() {
- cd ${S}
-
Xpath="`which X | sed -e "s:/bin/X$::"`"
Kversion=`uname -r`
dodir /lib/modules/${Kversion}/kernel/drivers/video
dodir /usr/include/GL ${Xpath}/lib/modules/drivers
dodir /usr/lib/opengl/mtx/extensions
- dodir /usr/lib/opengl/mtx/lib /usr/lib/opengl/mtx/include
+ dodir /usr/lib/opengl/mtx/lib /usr/lib/opengl/mtx/include
dodoc README* samples/*
@@ -81,8 +73,8 @@ src_install() {
}
pkg_postinst() {
- /sbin/depmod -a
- /sbin/ldconfig
+ /sbin/depmod -a
+ /sbin/ldconfig
opengl-update mtx
einfo "Please look at /usr/share/doc/${P}/XF86Config.* for"
einfo "X configurations for your Parhelia or Millenium P650/P750 card."
diff --git a/media-video/mtxdrivers/mtxdrivers-0.2.1.ebuild b/media-video/mtxdrivers/mtxdrivers-0.2.1.ebuild
index d01923ceb725..d7d95b00c000 100644
--- a/media-video/mtxdrivers/mtxdrivers-0.2.1.ebuild
+++ b/media-video/mtxdrivers/mtxdrivers-0.2.1.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers/mtxdrivers-0.2.1.ebuild,v 1.7 2003/04/20 02:43:20 darkspecter Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers/mtxdrivers-0.2.1.ebuild,v 1.8 2003/08/07 04:20:18 vapier Exp $
RELEASE=2002
-SRC_URI="ftp://ftp.matrox.com/pub/mga/archive/linux/${RELEASE}/${P/-/_}.tgz"
DESCRIPTION="Drviers for the Matrox Parhelia card."
HOMEPAGE="http://www.matrox.com/mga/products/parhelia/home.cfm"
+SRC_URI="ftp://ftp.matrox.com/pub/mga/archive/linux/${RELEASE}/${P/-/_}.tgz"
-DEPEND=">=x11-base/xfree-4.1.0
- virtual/kernel"
-
-SLOT="0"
LICENSE="Matrox"
+SLOT="0"
KEYWORDS="x86"
+DEPEND=">=x11-base/xfree-4.1.0
+ virtual/kernel"
+
Xversion=`X -version 2>&1 | grep -s "XFree86 Version" | cut -d" " -f3 | sed -e "s/\([^\.]*\.[^\.]*\.[^\.]*\)\.[^\.]*/\1/"`
src_unpack() {
@@ -22,8 +22,6 @@ src_unpack() {
}
src_compile() {
- cd ${S}
-
# hack to make mtx.o compile with rmap enabled kernels
if [ ${RMAPHACK} = "yes" ]; then
cp kernel/src/mtx_vm.c kernel/src/mtx_vm.c.orig
@@ -44,8 +42,6 @@ src_compile() {
}
src_install() {
- cd ${S}
-
Xpath="`which X | sed -e "s:/bin/X$::"`"
Kversion=`uname -r`
diff --git a/media-video/mtxdrivers/mtxdrivers-0.3.0.ebuild b/media-video/mtxdrivers/mtxdrivers-0.3.0.ebuild
index a5d72936e664..674f1a24d140 100644
--- a/media-video/mtxdrivers/mtxdrivers-0.3.0.ebuild
+++ b/media-video/mtxdrivers/mtxdrivers-0.3.0.ebuild
@@ -1,38 +1,37 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers/mtxdrivers-0.3.0.ebuild,v 1.4 2003/06/06 17:42:34 prez Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers/mtxdrivers-0.3.0.ebuild,v 1.5 2003/08/07 04:20:18 vapier Exp $
At="mtxdrivers-rh9.0-0.3.0.run"
-SRC_URI=""
DESCRIPTION="Drviers for the Matrox Parhelia and Millenium P650/P750 cards."
HOMEPAGE="http://www.matrox.com/mga/products/parhelia/home.cfm"
+SRC_URI="${At}"
-DEPEND=">=x11-base/xfree-4.2.0
- virtual/kernel
- !mtxdrivers-pro"
-
-SLOT="0"
LICENSE="Matrox"
+SLOT="0"
KEYWORDS="x86"
+RESTRICT="fetch"
+
+DEPEND=">=x11-base/xfree-4.2.0
+ virtual/kernel
+ !mtxdrivers-pro"
Xversion=`X -version 2>&1 | grep -s "XFree86 Version" | cut -d" " -f3 | sed -e "s/\([^\.]*\.[^\.]*\.[^\.]*\)\.[^\.]*/\1/"`
+pkg_nofetch() {
+ einfo "You must go to: http://www.matrox.com/mga/registration/home.cfm?refid=7667"
+ einfo "(for the RH9.0 drivers) and log in (or create an account) to download the"
+ einfo "Matrox Parhelia drivers. Remember to right-click and use Save Link As when"
+ einfo "downloading the driver."
+}
+
src_unpack() {
- if [ ! -f "${DISTDIR}/${At}" ]; then
- einfo "You must go to: http://www.matrox.com/mga/registration/home.cfm?refid=7667"
- einfo "(for the RH9.0 drivers) and log in (or create an account) to download the"
- einfo "Matrox Parhelia drivers. Remember to right-click and use Save Link As when"
- einfo "downloading the driver."
- die
- fi
mkdir ${S}
cd ${S}
tail -4434 "${DISTDIR}/${At}" | tar -xvzf -
}
src_compile() {
- cd ${S}
-
if [ ! -e ${S}/xfree86/${Xversion} ]; then
eerror "Matrox does not support XFree v${Xversion}"
exit 1
@@ -48,13 +47,11 @@ src_compile() {
}
src_install() {
- cd ${S}
-
Xpath="`which X | sed -e "s:/bin/X$::"`"
Kversion=`uname -r`
dodir /lib/modules/${Kversion}/kernel/drivers/video
- dodir ${Xpath}/lib/modules/drivers
+ dodir ${Xpath}/lib/modules/drivers
dodoc README* samples/*
diff --git a/media-video/nvclock/nvclock-0.6.2-r1.ebuild b/media-video/nvclock/nvclock-0.6.2-r1.ebuild
index ace52d0ceeda..d70d63d1f0f7 100644
--- a/media-video/nvclock/nvclock-0.6.2-r1.ebuild
+++ b/media-video/nvclock/nvclock-0.6.2-r1.ebuild
@@ -1,14 +1,19 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/nvclock/nvclock-0.6.2-r1.ebuild,v 1.1 2003/04/16 02:44:03 malverian Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/nvclock/nvclock-0.6.2-r1.ebuild,v 1.2 2003/08/07 04:14:55 vapier Exp $
-IUSE="gtk qt"
+inherit eutils
MY_P="${PN}${PV}"
-S=${WORKDIR}/${PN}${PV}
-SRC_URI="http://www.linuxhardware.org/nvclock/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
DESCRIPTION="NVIDIA Overclocking Utility"
HOMEPAGE="http://www.linuxhardware.org/nvclock/"
+SRC_URI="http://www.linuxhardware.org/nvclock/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="gtk qt"
DEPEND="virtual/glibc
sys-devel/autoconf
@@ -16,10 +21,6 @@ DEPEND="virtual/glibc
gtk2? ( =x11-libs/gtk+-2* )
qt? ( x11-libs/qt )"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
-
src_compile() {
epatch ${FILESDIR}/${PV}-configure.in.patch
use qt && epatch ${FILESDIR}/${PV}-qt-version-check.patch
diff --git a/media-video/quickrip/quickrip-0.4.ebuild b/media-video/quickrip/quickrip-0.4.ebuild
index 3da9aad202a1..a38479b0e5f2 100644
--- a/media-video/quickrip/quickrip-0.4.ebuild
+++ b/media-video/quickrip/quickrip-0.4.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/quickrip/quickrip-0.4.ebuild,v 1.4 2003/07/12 21:12:53 aliz Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/quickrip/quickrip-0.4.ebuild,v 1.5 2003/08/07 04:18:33 vapier Exp $
-inherit eutils
+inherit eutils
-MY_PV="$(echo ${PV} | cut -d. -f1,2)"
-S="${WORKDIR}/${PN}"
-DESCRIPTION="Basic DVD ripper written in Python and PyQT."
+MY_PV="$(echo ${PV} | cut -d. -f1,2)"
+S="${WORKDIR}/${PN}"
+DESCRIPTION="Basic DVD ripper written in Python and PyQT."
+HOMEPAGE="http://www.tomchance.uklinux.net/projects/quickrip.shtml"
SRC_URI="http://www.tomchance.uklinux.net/projects/${P}.tar.gz"
-HOMEPAGE="http://www.tomchance.uklinux.net/projects/quickrip.shtml"
-LICENSE="GPL-2"
-SLOT="0"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 -ppc -mips"
-IUSE=""
-DEPEND="virtual/glibc
- >=dev-lang/python-2.2
- >=x11-libs/qt-3.1
- >=dev-python/PyQt-3.5
- media-video/mplayer
- media-video/transcode"
+DEPEND="virtual/glibc
+ >=dev-lang/python-2.2
+ >=x11-libs/qt-3.1
+ >=dev-python/PyQt-3.5
+ media-video/mplayer
+ media-video/transcode"
-src_install() {
- exeinto /usr/share/quickrip
+src_install() {
+ exeinto /usr/share/quickrip
doexe *.py *.ui
dodoc README LICENSE
diff --git a/media-video/quickrip/quickrip-0.5.ebuild b/media-video/quickrip/quickrip-0.5.ebuild
index 23126f0c30b6..76ccb1403309 100644
--- a/media-video/quickrip/quickrip-0.5.ebuild
+++ b/media-video/quickrip/quickrip-0.5.ebuild
@@ -1,28 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/quickrip/quickrip-0.5.ebuild,v 1.3 2003/07/12 21:12:53 aliz Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/quickrip/quickrip-0.5.ebuild,v 1.4 2003/08/07 04:18:33 vapier Exp $
-inherit eutils
+inherit eutils
-MY_PV="$(echo ${PV} | cut -d. -f1,2)"
-S="${WORKDIR}/${PN}"
-DESCRIPTION="Basic DVD ripper written in Python and PyQT."
+MY_PV="$(echo ${PV} | cut -d. -f1,2)"
+S="${WORKDIR}/${PN}"
+DESCRIPTION="Basic DVD ripper written in Python and PyQT."
+HOMEPAGE="http://www.tomchance.uklinux.net/projects/quickrip.shtml"
SRC_URI="http://www.tomchance.uklinux.net/projects/${P}.tar.gz"
-HOMEPAGE="http://www.tomchance.uklinux.net/projects/quickrip.shtml"
-LICENSE="GPL-2"
-SLOT="0"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 -ppc -mips"
-IUSE=""
-DEPEND="virtual/glibc
- >=dev-lang/python-2.2
- >=x11-libs/qt-3.1
- >=dev-python/PyQt-3.5
- media-video/mplayer
- media-video/transcode"
+DEPEND="virtual/glibc
+ >=dev-lang/python-2.2
+ >=x11-libs/qt-3.1
+ >=dev-python/PyQt-3.5
+ media-video/mplayer
+ media-video/transcode"
-src_install() {
+src_install() {
exeinto /usr/share/quickrip
doexe *.py *.ui
diff --git a/media-video/quickrip/quickrip-0.6.ebuild b/media-video/quickrip/quickrip-0.6.ebuild
index 9a84541b5739..aa9864021789 100644
--- a/media-video/quickrip/quickrip-0.6.ebuild
+++ b/media-video/quickrip/quickrip-0.6.ebuild
@@ -1,28 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/quickrip/quickrip-0.6.ebuild,v 1.3 2003/07/12 21:12:53 aliz Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/quickrip/quickrip-0.6.ebuild,v 1.4 2003/08/07 04:18:33 vapier Exp $
-inherit eutils
+inherit eutils
-MY_PV="$(echo ${PV} | cut -d. -f1,2)"
+MY_PV="$(echo ${PV} | cut -d. -f1,2)"
S="${WORKDIR}/QuickRip"
-DESCRIPTION="Basic DVD ripper written in Python and PyQT."
+DESCRIPTION="Basic DVD ripper written in Python and PyQT."
+HOMEPAGE="http://www.tomchance.uklinux.net/projects/quickrip.shtml"
SRC_URI="http://www.tomchance.uklinux.net/projects/${P}.tar.gz"
-HOMEPAGE="http://www.tomchance.uklinux.net/projects/quickrip.shtml"
-LICENSE="GPL-2"
-SLOT="0"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 -ppc -mips"
-IUSE=""
-DEPEND="virtual/glibc
- >=dev-lang/python-2.2
- >=x11-libs/qt-3.1
- >=dev-python/PyQt-3.5
- media-video/mplayer
- media-video/transcode"
+DEPEND="virtual/glibc
+ >=dev-lang/python-2.2
+ >=x11-libs/qt-3.1
+ >=dev-python/PyQt-3.5
+ media-video/mplayer
+ media-video/transcode"
-src_install() {
+src_install() {
exeinto /usr/share/quickrip
doexe *.py ui/*.ui
diff --git a/media-video/quickrip/quickrip-0.7.ebuild b/media-video/quickrip/quickrip-0.7.ebuild
index d4bfef149424..9ba77b94e59b 100644
--- a/media-video/quickrip/quickrip-0.7.ebuild
+++ b/media-video/quickrip/quickrip-0.7.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/quickrip/quickrip-0.7.ebuild,v 1.1 2003/07/04 07:22:06 brain Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/quickrip/quickrip-0.7.ebuild,v 1.2 2003/08/07 04:18:33 vapier Exp $
-inherit eutils
+inherit eutils
S="${WORKDIR}/QuickRip"
DESCRIPTION="Basic DVD ripper written in Python and PyQT."
-SRC_URI="mirror://sourceforge/quickrip/${P}.tar.gz"
HOMEPAGE="http://quickrip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/quickrip/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 -ppc -mips"
-IUSE=""
DEPEND="virtual/glibc
>=dev-lang/python-2.2
diff --git a/media-video/recmpeg/recmpeg-1.0.5.ebuild b/media-video/recmpeg/recmpeg-1.0.5.ebuild
index 8f859994ebb6..0c40cc84b15c 100644
--- a/media-video/recmpeg/recmpeg-1.0.5.ebuild
+++ b/media-video/recmpeg/recmpeg-1.0.5.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-video/recmpeg/recmpeg-1.0.5.ebuild,v 1.4 2003/07/12 21:12:53 aliz Exp $
-
-IUSE="mmx sse"
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/recmpeg/recmpeg-1.0.5.ebuild,v 1.5 2003/08/07 04:15:15 vapier Exp $
DESCRIPTION="recmpeg is a simple video encoder, based on libfame, which compresses raw video sequences to MPEG video"
+HOMEPAGE="http://fame.sourceforge.net/"
SRC_URI="mirror://sourceforge/fame/${P}.tar.gz"
-HOMEPAGE="http://fame.sourceforge.net"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE="mmx sse"
DEPEND="virtual/glibc
>=media-libs/libfame-0.9.0"
diff --git a/media-video/usb-pwcx/usb-pwcx-8.2.2.ebuild b/media-video/usb-pwcx/usb-pwcx-8.2.2.ebuild
index 713c00e8062f..1a84f475be50 100644
--- a/media-video/usb-pwcx/usb-pwcx-8.2.2.ebuild
+++ b/media-video/usb-pwcx/usb-pwcx-8.2.2.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/usb-pwcx/usb-pwcx-8.2.2.ebuild,v 1.3 2003/02/13 13:36:13 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/usb-pwcx/usb-pwcx-8.2.2.ebuild,v 1.4 2003/08/07 04:15:32 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Optional closed source drivers for phillips webcams to allow for higher resoltions and framerates "
-SRC_URI="http://www.smcc.demon.nl/webcam/usb-pwcx-8.2.2.tar.gz"
HOMEPAGE="http://www.smcc.demon.nl/webcam/"
-SLOT="0"
+SRC_URI="http://www.smcc.demon.nl/webcam/usb-pwcx-8.2.2.tar.gz"
+
LICENSE="freedist"
+SLOT="0"
KEYWORDS="~x86 -ppc -sparc -alpha"
+
DEPEND=""
src_install() {
@@ -28,4 +29,3 @@ pkg_postinst() {
[ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
fi
}
-
diff --git a/media-video/vdr/vdr-1.1.27.ebuild b/media-video/vdr/vdr-1.1.27.ebuild
index efcfa3c8aa34..6cb3eea7281a 100644
--- a/media-video/vdr/vdr-1.1.27.ebuild
+++ b/media-video/vdr/vdr-1.1.27.ebuild
@@ -1,26 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-video/vdr/vdr-1.1.27.ebuild,v 1.4 2003/07/12 21:12:53 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vdr/vdr-1.1.27.ebuild,v 1.5 2003/08/07 04:16:26 vapier Exp $
inherit eutils
-IUSE="lirc"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Klaus Schmidingers Video Disk Recorder"
HOMEPAGE="http://www.cadsoft.de/people/kls/vdr"
SRC_URI="ftp://ftp.cadsoft.de/vdr/Developer/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE="lirc"
DEPEND="media-tv/linuxtv-dvb
sys-libs/ncurses
lirc? ( app-misc/lirc )
media-libs/jpeg"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -33,7 +30,7 @@ src_compile() {
emake ${myconf} || die "make failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "install failed"
dodoc COPYING INSTALL README MANUAL CONTRIBUTORS HISTORY
dohtml PLUGINS.html
diff --git a/media-video/w3cam/w3cam-0.7.2.ebuild b/media-video/w3cam/w3cam-0.7.2.ebuild
index 6cb541127118..87624cef9539 100644
--- a/media-video/w3cam/w3cam-0.7.2.ebuild
+++ b/media-video/w3cam/w3cam-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.4 2003/07/12 21:12:57 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.5 2003/08/07 04:16:04 vapier Exp $
#
# You can set the default device that vidcat and w3camd use by setting
@@ -10,19 +10,19 @@
# W3CAM_DEVICE="/dev/video0" emerge w3cam
#
-IUSE="truetype"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="w3cam - a set of small programs to grab images and videos from video4linux devices"
+DESCRIPTION="set of small programs to grab images and videos from video4linux devices"
HOMEPAGE="http://mpx.freeshell.org/"
SRC_URI="http://mpx.freeshell.org/${P}.tar.gz"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
-DEPEND="virtual/glibc \
- sys-libs/zlib \
- media-libs/jpeg \
- media-libs/libpng \
+IUSE="truetype"
+
+DEPEND="virtual/glibc
+ sys-libs/zlib
+ media-libs/jpeg
+ media-libs/libpng
truetype? ( media-libs/freetype )"
src_compile() {
@@ -52,4 +52,3 @@ src_install() {
docinto w3camd
dodoc w3camd/README w3camd/index.html w3camd/test.html w3camd/w3camd.fig
}
-
diff --git a/media-video/yanc/yanc-0.2.0.ebuild b/media-video/yanc/yanc-0.2.0.ebuild
index f7b9695b962c..0a73877dc5f4 100644
--- a/media-video/yanc/yanc-0.2.0.ebuild
+++ b/media-video/yanc/yanc-0.2.0.ebuild
@@ -1,31 +1,26 @@
# Copyright 2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/yanc/yanc-0.2.0.ebuild,v 1.1 2003/06/15 05:58:25 seemant Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/yanc/yanc-0.2.0.ebuild,v 1.2 2003/08/07 04:22:12 vapier Exp $
-
-S=${WORKDIR}/${P}
DESCRIPTION="YanC is a GUI configuration tool for the NVIDIA Accelerated Linux Driver Set."
HOMEPAGE="http://yanc.sourceforge.net/"
SRC_URI="mirror://sourceforge/yanc/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="-* ~x86"
-#
# As the downloaded package seems to be pre-compiled,
# the dependances are not clear.
# TODO: Emerge the real compilable yanc's code
-#
DEPEND=">=sys-apps/sed-4"
RDEPEND="x11-base/xfree"
-
src_compile() {
einfo "nothing to compile"
}
-src_install () {
+src_install() {
dodir /usr/share/yanc
dodir /usr/lib
dodir /usr/bin
@@ -52,12 +47,7 @@ src_install () {
}
pkg_postinst() {
- einfo ''
- einfo 'WARNING:'
- einfo '========'
einfo '-> Please create a copy of your XF86Config before you use YanC for the'
einfo 'first time, because it is possible that your XF86Config is damaged because of'
einfo 'the use of YanC. Then a restart of XFree would be impossible.'
- einfo ''
- echo ''
}