summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/dovecot/ChangeLog6
-rw-r--r--net-mail/dovecot/Manifest4
-rw-r--r--net-mail/dovecot/dovecot-1.0_alpha2.ebuild38
3 files changed, 30 insertions, 18 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index b6a2801ba3c1..cb216673de3a 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.29 2005/09/13 16:51:17 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.30 2005/09/13 21:42:06 wschlich Exp $
+
+ 13 Sep 2005; Wolfram Schlich <wschlich@gentoo.org>
+ dovecot-1.0_alpha2.ebuild:
+ fixups
*dovecot-1.0_alpha2 (13 Sep 2005)
diff --git a/net-mail/dovecot/Manifest b/net-mail/dovecot/Manifest
index c054a23ce557..2edd0d5cc2d6 100644
--- a/net-mail/dovecot/Manifest
+++ b/net-mail/dovecot/Manifest
@@ -1,10 +1,10 @@
-MD5 31554788900859e2c8c2830ac2f671cd ChangeLog 5719
+MD5 53032d7e335fe3dc3d15b1c5aff5ae89 ChangeLog 5811
MD5 f1a232989766277e9cbeea9d06ee295d dovecot-0.99.11-r1.ebuild 4758
MD5 6aff5aa92785e8c05383a2b4c174b645 dovecot-0.99.13.ebuild 4755
MD5 99447b7e91993e85c28780291d5656e6 dovecot-0.99.14-r1.ebuild 5068
MD5 e8a87e45204be10f963e561e52b711f7 dovecot-0.99.14.ebuild 4756
MD5 61e0d05b1306513aede2838fa81b05b5 metadata.xml 225
-MD5 bdbd929660c7a7699af7fd4069b7e857 dovecot-1.0_alpha2.ebuild 5317
+MD5 5d61659b291440014d20fe180ce752b8 dovecot-1.0_alpha2.ebuild 5434
MD5 3d6d703cf014f2defc8fed34b50849a9 files/digest-dovecot-0.99.11-r1 67
MD5 d7a52bb7835818feb1f4acd85eba3d57 files/digest-dovecot-0.99.13 67
MD5 2a50200054849ca5e0173cb709ef649d files/digest-dovecot-0.99.14 67
diff --git a/net-mail/dovecot/dovecot-1.0_alpha2.ebuild b/net-mail/dovecot/dovecot-1.0_alpha2.ebuild
index 38b8901b3820..afeefd7e6e6e 100644
--- a/net-mail/dovecot/dovecot-1.0_alpha2.ebuild
+++ b/net-mail/dovecot/dovecot-1.0_alpha2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_alpha2.ebuild,v 1.1 2005/09/13 16:51:17 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_alpha2.ebuild,v 1.2 2005/09/13 21:42:06 wschlich Exp $
-IUSE="debug ipv6 ldap mbox pam postgres sasl ssl gnutls vpopmail nopop3d mysql"
+IUSE="debug ipv6 ldap maildir mbox pam postgres sasl ssl gnutls vpopmail nopop3d mysql"
inherit eutils
DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
@@ -67,13 +67,25 @@ src_compile() {
#! use gnutls && ! use ssl && myconf="${myconf} --without-ssl"
useq vpopmail || myconf="${myconf} --without-vpopmail"
- econf ${myconf} || die "configure failed"
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ ${myconf} || die "configure failed"
emake || die "make failed"
}
src_install () {
einstall || die "make install failed"
+ # rc script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dovecot.init dovecot
+
# Create the dovecot.conf file from the dovecot-example.conf file that
# the dovecot folks nicely left for us....
mv ${D}/etc/dovecot-example.conf ${D}/etc/dovecot.conf
@@ -115,24 +127,20 @@ src_install () {
# Documentation
rm -rf ${D}/usr/share/doc/dovecot
dodoc AUTHORS COPYING* NEWS README TODO dovecot-example.conf
- dodoc doc/*.txt doc/*.conf doc/*.cnf
-
- # per default dovecot wants it ssl cert called dovecot.pem
- # fix this in mkcert.sh, which we use to generate the ssl certs
- sed -i -e 's/imapd.pem/dovecot.pem/g' doc/mkcert.sh
- dodoc doc/mkcert.sh
-
- # rc script
- exeinto /etc/init.d
- newexe ${FILESDIR}/dovecot.init dovecot
+ dodoc doc/*.txt doc/*.conf doc/*.cnf doc/mkcert.sh
# Create SSL certificates
if useq ssl || useq gnutls; then
dodir /etc/ssl/certs
dodir /etc/ssl/private
# Let's not make a new certificate if we already have one
- [ -e /etc/ssl/certs/dovecot.pem -a -e /etc/ssl/private/dovecot.pem ] \
- || SSLDIR=${D}/etc/ssl sh doc/mkcert.sh
+ if ! [[ -e /etc/ssl/certs/dovecot.pem && \
+ -e /etc/ssl/private/dovecot.pem ]]; then
+ einfo "Generating X.509 certificate for SSL"
+ pushd doc >/dev/null && \
+ SSLDIR=${D}/etc/ssl sh mkcert.sh && \
+ popd >/dev/null
+ fi
fi
dodir /var/run/dovecot