summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/dclib/ChangeLog14
-rw-r--r--net-p2p/dclib/dclib-0.2.5.ebuild33
-rw-r--r--net-p2p/dclib/files/dclib-0.2.5-gcc2.patch10
-rw-r--r--net-p2p/dclib/files/digest-dclib-0.2.51
-rw-r--r--net-p2p/qt-dcgui/ChangeLog13
-rw-r--r--net-p2p/qt-dcgui/files/digest-qt-dcgui-0.2.51
-rw-r--r--net-p2p/qt-dcgui/qt-dcgui-0.2.5.ebuild31
7 files changed, 93 insertions, 10 deletions
diff --git a/net-p2p/dclib/ChangeLog b/net-p2p/dclib/ChangeLog
index c957fd534cfa..23f89da728c7 100644
--- a/net-p2p/dclib/ChangeLog
+++ b/net-p2p/dclib/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for net-p2p/dclib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.15 2003/02/04 12:51:29 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.16 2003/02/11 06:13:54 vapier Exp $
- 04 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> dclib-0.2.4.ebuild :
- Marked stable becuse of security.
+*dclib-0.2.5 (11 Feb 2003)
+
+ 11 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #15459.
*dclib-0.2.4 (02 Feb 2003)
+ 04 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> dclib-0.2.4.ebuild :
+ Marked stable becuse of security.
+
02 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> :
Version bump.
@@ -14,8 +19,7 @@
27 Jan 2003; Joachim Blaabjerg <styx@gentoo.org> dclib-0.2.3.ebuild
files/digest-dclib-0.2.3 ChangeLog :
-
- Version bump to 0.2.3, partial fix of bug #14628
+ Version bump to 0.2.3, partial fix of bug #14628.
*dclib-0.2.1 (20 Jan 2003)
diff --git a/net-p2p/dclib/dclib-0.2.5.ebuild b/net-p2p/dclib/dclib-0.2.5.ebuild
new file mode 100644
index 000000000000..71f035afcece
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.2.5.ebuild,v 1.1 2003/02/11 06:13:54 vapier Exp $
+
+inherit gcc eutils
+
+DESCRIPTION="Library for the Qt client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://download.berlios.de/dcgui/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=sys-apps/bzip2-1.0.2
+ >=dev-libs/libxml2-2.4.22"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ [ `gcc-major-version` == 2 ] && epatch ${FILESDIR}/${P}-gcc2.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}
diff --git a/net-p2p/dclib/files/dclib-0.2.5-gcc2.patch b/net-p2p/dclib/files/dclib-0.2.5-gcc2.patch
new file mode 100644
index 000000000000..9554a2d050f0
--- /dev/null
+++ b/net-p2p/dclib/files/dclib-0.2.5-gcc2.patch
@@ -0,0 +1,10 @@
+--- dclib/cthread.cpp.orig 2002-12-19 19:01:57.000000000 -0500
++++ dclib/cthread.cpp 2002-12-19 19:02:09.000000000 -0500
+@@ -16,6 +16,7 @@
+ ***************************************************************************/
+
+ #include <stdio.h>
++#define __USE_POSIX199309
+ #include <time.h>
+ #include <errno.h>
+
diff --git a/net-p2p/dclib/files/digest-dclib-0.2.5 b/net-p2p/dclib/files/digest-dclib-0.2.5
new file mode 100644
index 000000000000..8ac6bd14e06a
--- /dev/null
+++ b/net-p2p/dclib/files/digest-dclib-0.2.5
@@ -0,0 +1 @@
+MD5 a33c6f1093cb9ec13d3c94e5cdcd5f9e dclib-0.2.5.tar.bz2 469054
diff --git a/net-p2p/qt-dcgui/ChangeLog b/net-p2p/qt-dcgui/ChangeLog
index 474910496f6b..fc7fd600af5d 100644
--- a/net-p2p/qt-dcgui/ChangeLog
+++ b/net-p2p/qt-dcgui/ChangeLog
@@ -1,15 +1,19 @@
# ChangeLog for net-p2p/qt-dcgui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/ChangeLog,v 1.15 2003/02/04 12:51:29 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/ChangeLog,v 1.16 2003/02/11 06:15:14 vapier Exp $
- 04 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> qt-dcgui-0.2.4.ebuild :
- Marked stable becuse of security.
+*qt-dcgui-0.2.5 (11 Feb 2003)
+
+ 11 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #15459.
*qt-dcgui-0.2.4 (02 Feb 2003)
+ 04 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> qt-dcgui-0.2.4.ebuild :
+ Marked stable becuse of security.
+
02 Feb 2003; Joachim Blaabjerg <styx@gentoo.org> qt-dcgui-0.2.4.ebuild
files/digest-qt-dcgui-0.2.4 ChangeLog :
-
Actual bump ;), and hopefully fixed bug #14893 by inheriting kde-functions.
Removed old ebuilds.
@@ -20,7 +24,6 @@
27 Jan 2003; Joachim Blaabjerg <styx@gentoo.org> qt-dcgui-0.2.3.ebuild
files/digest-qt-dcgui-0.2.3 ChangeLog :
-
Version bump to 0.2.3, fixes bug #14628
*qt-dcgui-0.2.1 (20 Jan 2003)
diff --git a/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.2.5 b/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.2.5
new file mode 100644
index 000000000000..c7d9d9a798b2
--- /dev/null
+++ b/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.2.5
@@ -0,0 +1 @@
+MD5 9926cafe0d74796210a44df6d40b8970 dcgui-0.2.5.tar.bz2 645951
diff --git a/net-p2p/qt-dcgui/qt-dcgui-0.2.5.ebuild b/net-p2p/qt-dcgui/qt-dcgui-0.2.5.ebuild
new file mode 100644
index 000000000000..ff2c9484f737
--- /dev/null
+++ b/net-p2p/qt-dcgui/qt-dcgui-0.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/qt-dcgui-0.2.5.ebuild,v 1.1 2003/02/11 06:15:14 vapier Exp $
+
+inherit kde-functions
+
+MY_P="${P/qt-/}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Qt based client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://download.berlios.de/dcgui/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+need-qt 3
+newdepend ">=dev-libs/libxml2-2.4.22
+ ~net-p2p/dclib-${PV}"
+
+src_compile() {
+ econf --with-libdc=/usr \
+ --with-qt-dir=/usr/qt/3 \
+ || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}