summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/qhacc/Manifest20
-rw-r--r--app-office/qhacc/qhacc-3.2.2.ebuild26
2 files changed, 30 insertions, 16 deletions
diff --git a/app-office/qhacc/Manifest b/app-office/qhacc/Manifest
index 82107af37553..08d943e1ecdf 100644
--- a/app-office/qhacc/Manifest
+++ b/app-office/qhacc/Manifest
@@ -1,10 +1,20 @@
-MD5 cc231cd13bdb8a57627c09c88d1f717e qhacc-3.2.1.ebuild 1903
-MD5 54bb00bdb2ef11c32664a49224c6ae82 qhacc-3.2.2.ebuild 1936
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 213cf0b0848ee5f1bf1bacc0822c04ac ChangeLog 3139
MD5 512150b47a904b0240101e319856aab1 metadata.xml 156
-MD5 27867aca5f38687a4e9bd740005e9996 files/qhacc-3.2.2-sandbox.patch 21441
+MD5 cc231cd13bdb8a57627c09c88d1f717e qhacc-3.2.1.ebuild 1903
+MD5 035bf8821c9f6bc536dbc5ebe9b4ff08 qhacc-3.2.2.ebuild 1935
+MD5 8ad038ef57072d0bd84121a74aa30c59 files/digest-qhacc-3.2.1 63
MD5 5d4fad5c5dece54cf6376b1cbf836667 files/qhacc-3.2.1-mysql_plugin_libs.patch 834
MD5 2f6b026212a58b32e415bede86478bba files/qhacc-3.2.1-psql_plugin_libs.patch 822
-MD5 8ad038ef57072d0bd84121a74aa30c59 files/digest-qhacc-3.2.1 63
-MD5 4fe6fcff9b37a9455d289ec9e47705e6 files/digest-qhacc-3.2.2 63
MD5 a17438e255e4c609d23b7db1e10761c9 files/qhacc-3.2.1-sandbox.patch 14903
+MD5 4fe6fcff9b37a9455d289ec9e47705e6 files/digest-qhacc-3.2.2 63
+MD5 27867aca5f38687a4e9bd740005e9996 files/qhacc-3.2.2-sandbox.patch 21441
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBxu6rroRuSHgZdywRAmR5AKCL9oie6zUsd88oVaiv9woeS6QwsQCfapAa
+ShbONDcRxhB/sb07iTJjdRg=
+=koHp
+-----END PGP SIGNATURE-----
diff --git a/app-office/qhacc/qhacc-3.2.2.ebuild b/app-office/qhacc/qhacc-3.2.2.ebuild
index 118164361c5e..87c8180902fa 100644
--- a/app-office/qhacc/qhacc-3.2.2.ebuild
+++ b/app-office/qhacc/qhacc-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/qhacc/qhacc-3.2.2.ebuild,v 1.1 2004/10/29 19:00:00 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/qhacc/qhacc-3.2.2.ebuild,v 1.2 2004/12/20 15:24:07 vapier Exp $
inherit libtool kde-functions eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/qhacc/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+KEYWORDS="~alpha ~hppa ~ppc ~sparc ~x86"
IUSE="doc mysql ofx postgres sqlite"
DEPEND="ofx? ( ~dev-libs/libofx-0.7.0 )
@@ -31,14 +31,18 @@ src_unpack() {
}
src_compile() {
- local myconf="--libdir=/usr/lib/qhacc --bindir=/usr/bin --includedir=/usr/include --datadir=/usr/share/qhacc
- $(use_enable mysql)
- $(use_enable postgres psql)
- $(use_enable sqlite)
- $(use_enable ofx) $(use_with ofx ofx-includes /usr/include/libofx)"
-
- econf ${myconf} || die "./configure failed"
- emake -j 1 || die "make failed"
+ econf \
+ --libdir=/usr/lib/qhacc \
+ --bindir=/usr/bin \
+ --includedir=/usr/include \
+ --datadir=/usr/share/qhacc \
+ $(use_enable mysql) \
+ $(use_enable postgres psql) \
+ $(use_enable sqlite) \
+ $(use_enable ofx) \
+ $(use_with ofx ofx-includes /usr/include/libofx) \
+ || die "./configure failed"
+ emake -j1 || die "make failed"
}
src_install() {
@@ -50,7 +54,7 @@ src_install() {
insinto /usr/share/qhacc/easysetup
doins ${S}/contrib/easysetup/*
rm -rf ${D}/var
- dodoc AUTHORS ChangeLog COPYING FILE_FORMAT INSTALL NEWS README THANKS TODO UPGRADE
+ dodoc AUTHORS ChangeLog FILE_FORMAT INSTALL NEWS README THANKS TODO UPGRADE
}
pkg_postinst() {