summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/unreal-tournament-goty/ChangeLog6
-rw-r--r--games-fps/unreal-tournament-goty/Manifest6
-rw-r--r--games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild77
-rw-r--r--games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild77
4 files changed, 86 insertions, 80 deletions
diff --git a/games-fps/unreal-tournament-goty/ChangeLog b/games-fps/unreal-tournament-goty/ChangeLog
index 7addac55a7ca..e0df0b0dddd6 100644
--- a/games-fps/unreal-tournament-goty/ChangeLog
+++ b/games-fps/unreal-tournament-goty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/unreal-tournament-goty
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/ChangeLog,v 1.6 2005/08/10 19:28:01 r3pek Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/ChangeLog,v 1.7 2005/09/16 03:00:32 mr_bones_ Exp $
+
+ 16 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ unreal-tournament-goty-436.ebuild, unreal-tournament-goty-451.ebuild:
+ needs app-arch/unzip; tidy
10 Aug 2005; Carlos Silva <r3pek@gentoo.org>
unreal-tournament-goty-451.ebuild:
diff --git a/games-fps/unreal-tournament-goty/Manifest b/games-fps/unreal-tournament-goty/Manifest
index 8bbb0ee7ed1b..095fd3350634 100644
--- a/games-fps/unreal-tournament-goty/Manifest
+++ b/games-fps/unreal-tournament-goty/Manifest
@@ -1,6 +1,6 @@
-MD5 d77f61468deadcd7faf2f53422c493b7 ChangeLog 1156
MD5 745cf2302a475c4f92c2aae453c20c14 metadata.xml 1595
-MD5 24240fdc76cfe5a50999ec11bf391041 unreal-tournament-goty-436.ebuild 4734
-MD5 12c42e5d670580c1ea4cb15ef36f585f unreal-tournament-goty-451.ebuild 4874
+MD5 ffbd5347e8470aceba307909cb8edd32 unreal-tournament-goty-451.ebuild 5021
+MD5 96abb9c2049cf1ef48e332498d7ec856 unreal-tournament-goty-436.ebuild 4862
+MD5 2e9c2b0b21290455204b1e2a098afa61 ChangeLog 1317
MD5 9410f0d78776e5b045bf0f47226a7cd7 files/digest-unreal-tournament-goty-436 142
MD5 1cbaec035f9fd4841f609ff9edbe9959 files/digest-unreal-tournament-goty-451 135
diff --git a/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild b/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
index d9de4f269512..c1f573504570 100644
--- a/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
+++ b/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v 1.7 2005/05/12 12:13:34 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v 1.8 2005/09/16 03:00:32 mr_bones_ Exp $
inherit eutils games
@@ -14,7 +14,8 @@ SLOT="0"
KEYWORDS="x86"
IUSE="3dfx S3TC nls opengl"
-DEPEND="!games-fps/unreal-tournament"
+DEPEND="!games-fps/unreal-tournament
+ app-arch/unzip"
RDEPEND="virtual/x11
opengl? ( virtual/opengl )"
@@ -33,55 +34,55 @@ src_unpack() {
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN/-goty/}
local Ddir=${D}/${dir}
- dodir ${dir}
+ dodir "${dir}"
###########
### PRE ###
# System
if use 3dfx ; then
- tar -zxf Glide.ini.tar.gz -C ${Ddir} || die "install Glide ini"
+ tar -zxf Glide.ini.tar.gz -C "${Ddir}" || die "install Glide ini"
else
- tar -zxf OpenGL.ini.tar.gz -C ${Ddir} || die "install OpenGL ini"
+ tar -zxf OpenGL.ini.tar.gz -C "${Ddir}" || die "install OpenGL ini"
fi
- tar -zxf data.tar.gz -C ${Ddir} || die "extract System data"
+ tar -zxf data.tar.gz -C "${Ddir}" || die "extract System data"
# the most important things, ucc & ut :)
- exeinto ${dir}
+ exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
- dosed "s:\`FindPath \$0\`:${dir}:" ${dir}/ucc
+ dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
# export some symlinks so ppl can run
- dodir ${GAMES_BINDIR}
- dosym ${dir}/ucc ${GAMES_BINDIR}/ucc
- dosym ${dir}/ut ${GAMES_BINDIR}/ut
+ dodir "${GAMES_BINDIR}"
+ dosym "${dir}"/ucc "${GAMES_BINDIR}"/ucc
+ dosym "${dir}"/ut "${GAMES_BINDIR}"/ut
### PRE ###
###########
###########
### CD1 ###
# Help, Logs, Music, Sounds, Textures, Web
- cp -rf "${CDROM_ROOT}"/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
- dodir ${dir}/Sounds
+ cp -rf "${CDROM_ROOT}"/{Help,Logs,Music,Textures,Web} "${Ddir}"/ || die "copy Help, Logs, Music, Textures, Web CD1"
+ dodir "${dir}"/Sounds
if use nls ; then
- cp -rf "${CDROM_ROOT}"/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf "${CDROM_ROOT}"/Sounds/* "${Ddir}"/Sounds/ || die "copy Sounds CD1"
else
- cp -rf "${CDROM_ROOT}"/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf "${CDROM_ROOT}"/Sounds/*.uax "${Ddir}"/Sounds/ || die "copy Sounds CD1"
fi
# System
- dodir ${dir}/System
+ dodir "${dir}"/System
if use nls ; then
- cp "${CDROM_ROOT}"/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp "${CDROM_ROOT}"/System/*.{est,frt,itt,int,u} "${Ddir}"/System/ || die "copy System data CD1"
else
- cp "${CDROM_ROOT}"/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp "${CDROM_ROOT}"/System/*.{int,u} "${Ddir}"/System/ || die "copy System data CD1"
fi
# now we uncompress the maps
einfo "Uncompressing CD1 Maps ... this may take some time"
- dodir ${dir}/Maps
- cd ${Ddir}
+ dodir "${dir}"/Maps
+ cd "${Ddir}"
export HOME=${T}
- export UT_DATA_PATH=${Ddir}/System
+ export UT_DATA_PATH="${Ddir}"/System
for f in `find "${CDROM_ROOT}"/Maps/ -name '*.uz' -printf '%f '` ; do
./ucc decompress "${CDROM_ROOT}"/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD1 ${f}"
@@ -95,24 +96,24 @@ src_install() {
###########
### CD2 ###
# Help, Sounds
- cp -rf "${CDROM_ROOT}"/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
+ cp -rf "${CDROM_ROOT}"/{Help,Sounds} "${Ddir}"/ || die "copy Help, Sounds CD2"
# S3TC Textures
if use S3TC ; then
- cp -rf "${CDROM_ROOT}"/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
+ cp -rf "${CDROM_ROOT}"/Textures "${Ddir}"/ || die "copy S3TC Textures CD2"
else
- cp -rf "${CDROM_ROOT}"/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
+ cp -rf "${CDROM_ROOT}"/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx "${Ddir}"/Textures/ || die "copy Textures CD2"
fi
# System
- cp -rf "${CDROM_ROOT}"/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
+ cp -rf "${CDROM_ROOT}"/System/*.{u,int} "${Ddir}"/System/ || die "copy System CD2"
# now we uncompress the maps
einfo "Uncompressing CD2 Maps ... this may take some time"
- dodir ${dir}/Maps
- cd ${Ddir}
+ dodir "${dir}"/Maps
+ cd "${Ddir}"
export HOME=${T}
- export UT_DATA_PATH=${Ddir}/System
+ export UT_DATA_PATH="${Ddir}"/System
for f in `find "${CDROM_ROOT}"/maps/ -name '*.uz' -printf '%f '` ; do
./ucc decompress "${CDROM_ROOT}"/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD2 ${f}"
@@ -122,32 +123,32 @@ src_install() {
###########
### END ###
- cd ${S}
+ cd "${S}"
# Textures
- tar -zxf Credits.tar.gz -C ${Ddir} || die "extract credits texture"
+ tar -zxf Credits.tar.gz -C "${Ddir}" || die "extract credits texture"
# NetGamesUSA.com
- tar -zxf NetGamesUSA.com.tar.gz -C ${Ddir}/ || die "extract NetGamesUSA.com"
+ tar -zxf NetGamesUSA.com.tar.gz -C "${Ddir}"/ || die "extract NetGamesUSA.com"
# Patch UT-GOTY
cd setup.data
- cp patch.dat{,.orig}
- sed -e 's:sh uz-maps.sh:echo:' patch.dat.orig > patch.dat
- ./bin/Linux/x86/loki_patch patch.dat ${Ddir} || die "failed to patch"
- cd ${S}
+ cp patch.dat{,.orig} || die "cp failed"
+ sed -e 's:sh uz-maps.sh:echo:' patch.dat.orig > patch.dat || die "sed failed"
+ ./bin/Linux/x86/loki_patch patch.dat "${Ddir}" || die "failed to patch"
+ cd "${S}"
# now we install the IpDrv.so patch
- insinto ${dir}/System
+ insinto "${dir}"/System
doins IpDrv.so || die "install IpDrv.so patch"
# install a few random files
- insinto ${dir}
+ insinto "${dir}"
doins README icon.{bmp,xpm} || die "installing random files"
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find ${Ddir} -exec touch '{}' \;
+ find "${Ddir}" -exec touch '{}' \;
### END ###
###########
diff --git a/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild b/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
index b1c206cbce3a..122b9939de29 100644
--- a/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
+++ b/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v 1.9 2005/08/10 19:28:01 r3pek Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v 1.10 2005/09/16 03:00:32 mr_bones_ Exp $
inherit games eutils
@@ -18,7 +18,8 @@ RDEPEND="virtual/x11
=media-libs/libsdl-1.2*
opengl? ( virtual/opengl )"
DEPEND="${RDEPEND}
- !games-fps/unreal-tournament"
+ !games-fps/unreal-tournament
+ app-arch/unzip"
S=${WORKDIR}
@@ -37,55 +38,55 @@ src_unpack() {
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN/-goty/}
local Ddir=${D}/${dir}
- dodir ${dir}
+ dodir "${dir}"
###########
### PRE ###
# System
if use 3dfx ; then
- tar -zxf Glide.ini.tar.gz -C ${Ddir} || die "install Glide ini"
+ tar -zxf Glide.ini.tar.gz -C "${Ddir}" || die "install Glide ini"
else
- tar -zxf OpenGL.ini.tar.gz -C ${Ddir} || die "install OpenGL ini"
+ tar -zxf OpenGL.ini.tar.gz -C "${Ddir}" || die "install OpenGL ini"
fi
- tar -zxf data.tar.gz -C ${Ddir} || die "extract System data"
+ tar -zxf data.tar.gz -C "${Ddir}" || die "extract System data"
# the most important things, ucc & ut :)
- exeinto ${dir}
+ exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
- dosed "s:\`FindPath \$0\`:${dir}:" ${dir}/ucc
+ dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
# export some symlinks so ppl can run
dodir ${GAMES_BINDIR}
- dosym ${dir}/ucc ${GAMES_BINDIR}/ucc
- dosym ${dir}/ut ${GAMES_BINDIR}/ut
+ dosym "${dir}"/ucc ${GAMES_BINDIR}/ucc
+ dosym "${dir}"/ut ${GAMES_BINDIR}/ut
### PRE ###
###########
###########
### CD1 ###
# Help, Logs, Music, Sounds, Textures, Web
- cp -rf "${CDROM_ROOT}"/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
- dodir ${dir}/Sounds
+ cp -rf "${CDROM_ROOT}"/{Help,Logs,Music,Textures,Web} "${Ddir}"/ || die "copy Help, Logs, Music, Textures, Web CD1"
+ dodir "${dir}"/Sounds
if use nls ; then
- cp -rf "${CDROM_ROOT}"/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf "${CDROM_ROOT}"/Sounds/* "${Ddir}"/Sounds/ || die "copy Sounds CD1"
else
- cp -rf "${CDROM_ROOT}"/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf "${CDROM_ROOT}"/Sounds/*.uax "${Ddir}"/Sounds/ || die "copy Sounds CD1"
fi
# System
- dodir ${dir}/System
+ dodir "${dir}"/System
if use nls ; then
- cp "${CDROM_ROOT}"/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp "${CDROM_ROOT}"/System/*.{est,frt,itt,int,u} "${Ddir}"/System/ || die "copy System data CD1"
else
- cp "${CDROM_ROOT}"/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp "${CDROM_ROOT}"/System/*.{int,u} "${Ddir}"/System/ || die "copy System data CD1"
fi
# now we uncompress the maps
einfo "Uncompressing CD1 Maps ... this may take some time"
- dodir ${dir}/Maps
- cd ${Ddir}
+ dodir "${dir}"/Maps
+ cd "${Ddir}"
export HOME=${T}
- export UT_DATA_PATH=${Ddir}/System
+ export UT_DATA_PATH="${Ddir}"/System
for f in `find "${CDROM_ROOT}"/Maps/ -name '*.uz' -printf '%f '` ; do
./ucc decompress "${CDROM_ROOT}"/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD1 ${f}"
@@ -99,24 +100,24 @@ src_install() {
###########
### CD2 ###
# Help, Sounds
- cp -rf "${CDROM_ROOT}"/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
+ cp -rf "${CDROM_ROOT}"/{Help,Sounds} "${Ddir}"/ || die "copy Help, Sounds CD2"
# S3TC Textures
if use S3TC ; then
- cp -rf "${CDROM_ROOT}"/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
+ cp -rf "${CDROM_ROOT}"/Textures "${Ddir}"/ || die "copy S3TC Textures CD2"
else
- cp -rf "${CDROM_ROOT}"/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
+ cp -rf "${CDROM_ROOT}"/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx "${Ddir}"/Textures/ || die "copy Textures CD2"
fi
# System
- cp -rf "${CDROM_ROOT}"/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
+ cp -rf "${CDROM_ROOT}"/System/*.{u,int} "${Ddir}"/System/ || die "copy System CD2"
# now we uncompress the maps
einfo "Uncompressing CD2 Maps ... this may take some time"
- dodir ${dir}/Maps
- cd ${Ddir}
+ dodir "${dir}"/Maps
+ cd "${Ddir}"
export HOME=${T}
- export UT_DATA_PATH=${Ddir}/System
+ export UT_DATA_PATH="${Ddir}"/System
for f in `find "${CDROM_ROOT}"/maps/ -name '*.uz' -printf '%f '` ; do
./ucc decompress "${CDROM_ROOT}"/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD2 ${f}"
@@ -126,33 +127,33 @@ src_install() {
###########
### END ###
- cd ${S}
+ cd "${S}"
# Textures
- tar -zxf Credits.tar.gz -C ${Ddir} || die "extract credits texture"
+ tar -zxf Credits.tar.gz -C "${Ddir}" || die "extract credits texture"
# NetGamesUSA.com
- tar -zxf NetGamesUSA.com.tar.gz -C ${Ddir}/ || die "extract NetGamesUSA.com"
+ tar -zxf NetGamesUSA.com.tar.gz -C "${Ddir}"/ || die "extract NetGamesUSA.com"
# first apply any patch remaints loki has for us
cd setup.data
- cp patch.dat{,.orig}
- sed -e 's:sh uz-maps.sh:echo:' patch.dat.orig > patch.dat
- ./bin/Linux/x86/loki_patch patch.dat ${Ddir} >& /dev/null
- cd ${S}
+ cp patch.dat{,.orig} || die "cp failed"
+ sed -e 's:sh uz-maps.sh:echo:' patch.dat.orig > patch.dat || die "sed failed"
+ ./bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null
+ cd "${S}"
# finally, unleash the UTPG patch
- cp -rf UTPG/* ${Ddir}/
+ cp -rf UTPG/* "${Ddir}"/ || die "cp failed"
# fix a small bug until next official release
- dosed "/^LoadClassMismatch/s:%s.%s:%s:" ${dir}/System/Core.int
+ dosed "/^LoadClassMismatch/s:%s.%s:%s:" "${dir}"/System/Core.int
# install a few random files
- insinto ${dir}
+ insinto "${dir}"
doins README icon.{bmp,xpm} || die "installing random files"
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find ${Ddir} -exec touch '{}' \;
+ find "${Ddir}" -exec touch '{}' \;
### END ###
###########